cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sudheermadduru
Helper III
Helper III

Showing False in the if condition even though drop down column value exists

Hi,

 

I have a sharepoint column called 'Region' of type Choice.

 

So if user select Europe under Region column,an email alert should be triggered to the mentioned user.

 

For this,I have user template of Start approval when a new item is added

 

In this I have added if condition,in the condition have set as 'Region is equal to Europe'.

 

In the advanced mode it is showing as @equals(triggerBody()?['Region'], 'Europe')

 

Email action has been set in the yes block of if condition

 

But when user is selecting Europe under Region column,it is not triggering an email.

 

In the flow history,under if condition it has been displayed as false under Expression result of if condition.

 

Please let me know if I am making any mistake here as I am newly using MS flows.

 

Regards,

Sudheer

1 ACCEPTED SOLUTION

Accepted Solutions
v-yuazh-msft
Community Support
Community Support

Hi @sudheermadduru,

 

Could you please share a screenshot of the configuration of your flow?

 

 

Please take a try to modify the expression in the Condition as below:

@equals(triggerBody()?['Region']?['Value'], 'Europe')

 

You should choose the "Region Value" dynamic content of the trigger to get the value of "Region" column.

 

I have made a test on my side and I have create a flow as below:

Capture.PNG

 

When an item is created in the list and the value of "Region" column is equal to "Europe", the flow would run successfully to start an approval as below:

Capture.PNG

 

 

 

Regards,
Alice Zhang

View solution in original post

6 REPLIES 6
ScottShearer
Super User
Super User

Can you post a screen shot of your Flow?  That may help shed some light on the root cause of your issue.

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Sorry,

 

I am not able to find the suitable option to upload the screen shot.

Please help me on this.

 

Regards,

Sudheer

One way would be to open any of the Office desktop apps and go to the insert ribbon.  Then select screenshot/screen clipping.  Then select just that part of the screen that you want to capture.  

 

After you capture the image, right click of it in the Office app and select "Save as Picture".  Save the picture to OneDrive and share it out.  Post a link to the image here.

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
v-yuazh-msft
Community Support
Community Support

Hi @sudheermadduru,

 

Could you please share a screenshot of the configuration of your flow?

 

 

Please take a try to modify the expression in the Condition as below:

@equals(triggerBody()?['Region']?['Value'], 'Europe')

 

You should choose the "Region Value" dynamic content of the trigger to get the value of "Region" column.

 

I have made a test on my side and I have create a flow as below:

Capture.PNG

 

When an item is created in the list and the value of "Region" column is equal to "Europe", the flow would run successfully to start an approval as below:

Capture.PNG

 

 

 

Regards,
Alice Zhang

View solution in original post

These things are not "solved" by any means. I'm testing Flow in our environment and I always get the same results. Works a time or two but later the same day or the next day, the logic fails totally. I've even had a simple flow check the status of an item, send either a true email or false email so I could test what it was doing, and it's fired BOTH emails on the same status check.

This has become horribly unreliable and the only way I've been able to correct it is to edit the flow, delete the Document Status Value field, re-add the field and update the flow.

It works for a day or so, then fails again.

Can anyone explain how we are supposed to move to Flow when we are forced to use the Modern Experience?

luizhr
Frequent Visitor

I solved the issue following this instruction below: 

 

condition returns false on choice field | Power Automate Exchange (flowug.com)

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,506)