cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
tn00629819R
Frequent Visitor

Start and wait for an approval (V2) is gone

 

Hi,

I don't know why it was gone suddenly. I can see them before around in 2019/7/21, AM:11:00, also use "Start and wait for an approval" of function with no problem. After lunch, my Start and wait for an approval" of function is not work and will have below message.

 

Could not retrieve values. undefined

1.jpg


I also found I can't see Start and wait for an approval (V2) show in Approvals... If anyone have the same issue yesterday...?  Thanks very much.

 

Now:

2.jpg

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Before:

3.jpg

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @tn00629819R 

 

That could be because we might be in different deployment regions (Dr. Flow had suggested this). The V2 will eventually be removed and replace the legacy ones. You can go ahead and use the "Start and wait for an approval" as usual one. 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

11 REPLIES 11

@tn00629819R 

Hi there.  I think there's an issue with a few connectors / actions.  I'm seeing some weirdness, as well.

 

Maybe check again later today.

-Ed-

 

 

If this reply has answered your question or resolved your challenge, please consider marking it as a Solution. This helps other users find it more easily via search.

yashag2255
Dual Super User II
Dual Super User II

HI @tn00629819R 

 

Please see the screenshots below:

A11.PNG

A2.PNG

You will see the other actions once you click on the approvals icon in screenshot 1. 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Hi All,

Thanks for reply, I dont' know why the "Start and wait for an approval" can be use and workable since yesterday, thanks very much.

 

But I still can't see "Start and wait for an approval (V2)" although already try to log off / login in  Microsoft Flow Community, deleted the temporary internet files on IE...etc.

 

2019-07-22_10-23-31.jpg

 

Hi @tn00629819R 

 

That could be because we might be in different deployment regions (Dr. Flow had suggested this). The V2 will eventually be removed and replace the legacy ones. You can go ahead and use the "Start and wait for an approval" as usual one. 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

I am having the same issue as the OP -- my "start and wait for an approval (V2)" is gone.   It would be no problem to use the other "start and wait for an apprvoal" option that is still there, except that it doesn't work correctly when only one person needs to make the approval. 

 

On the "V2", if you selected the option for "approve/reject - first to respond", then you could later use the dynamic data for that single approvers response, comments, etc.   However, on the remaining "start and wait for an approval" option, if you select the type as "first to respond" it doesn't recognize that you should only be getting one approval--it wants to put an "apply to each" box around everything, which gets to be a problem in a large flow since you can only nest so many "apply to each" boxes.   Please address!  Is there a workaround?

gdb789
Frequent Visitor

Exactly the same problem here, but found a workaround by manually extract the 1 single response from the 'responses' result, as in here:

ApprovalSingleResponse.jpg

first(body('Start_and_wait_for_an_approval')?['responses']).approverResponse
 
Note that the check condition that follows now becomes case sensitive (i.e. ApproverResponse = 'Approve'), instead of from before when the 'Response' variable is directly used, the lowercase 'approve' would just work (if I remember correctly.)

 

I had high hopes for your workaround and honestly appreciate your response, but when I tried it using Start and Wait for an Approval, no matter what expression I try, when i try to select the Dynamic content the list of available options has already reduced down to only:

Approval ID

Body

Completion Date

Details

Item Link

Item Link Description

Outcome

Request Date

Response Summary

Title

 

None of the "plural" options show. Just wondering, are you still able to create this expression or perhaps Microsoft has deployed this change in your region since? I'm specifically trying to update my sharepoint list with the Comment, Response, Approver Name and Response Date.

gdb789
Frequent Visitor

Sorry for late reply.  Hope your problem is already solved, or hope my response below help

 

Dynamic Contents are fixed and don't help in your (our) case.  You need to construct the singular field from the 1-element responses array.  From the 'responses' output:

 

{
  "responses": [
    {
      "responder": {
        "id": "iwofjoiwjfiwpfjopwijfopwqjfopqw",
        "displayName": "Approver Name",
        "email": "approver@company.onmicrosoft.com",
        "tenantId": "fwiopfwqaipofjopwfjopiwajfioawepfe",
        "userPrincipalName": "approver@company.onmicrosoft.com"
      },
      "requestDate": "2019-07-26T09:13:48Z",
      "responseDate": "2019-07-26T09:15:27Z",
      "approverResponse": "Approve",
      "comments": "Approval comment goes here"
    }
  ],
  ...
}

 

The values you need may be:

 

Comment - first(body('Start_and_wait_for_an_approval')?['responses']).comments

Response - first(body('Start_and_wait_for_an_approval')?['responses']).approverResponse

Approver Name - first(body('Start_and_wait_for_an_approval')?['responses']).responder.displayName

Response Date - first(body('Start_and_wait_for_an_approval')?['responses']).responseDate

 

HTH

So Microsoft eliminated an action with functionality that people needed, and now we have to code our own workaround with a different variable for every piece of data that we need to extract? How does that make any sense? This will be incredibly messy and clunky for flows with multiple approvals or multiple paths of approvals. Is anyone working on bringing back the V2 Approval action, or at least a new action that has the same function???
gdb789
Frequent Visitor

Can't agree more

Or make it customizable (1 or multiple approvers) via the 'Advanced' menu for example
I go bananas every time I see the dreaded "Apply to Each" crop up when I least expect it - and there's no 'undo' yet

Thank you, this really helped

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (1,563)