cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
samsam
Level: Powered On

Status:400 The specified user could not be found

Hi, 

 

I received an error of "Status:400 The specified user could not be found.", when it is in "Create Item" step.
That is a "Person / Group" field in SharePoint's List

 

No error comes up when the ComboBox's field has 1 record only.

However, when the ComboBox's field has 2 or more records, the error comes up

 

I tried below, and result are the same.
Choices('LG013-DataCenterVisitRequestLog'.'Request by Representative')
Office365Users.SearchUser({searchTerm:ComboBox2.SearchText})

 

Anybody can help?

 

Q20a.PNGQ20b.PNGQ20c.PNG

 

Thanks in advance
Sam

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Status:400 The specified user could not be found

Hi @samsam ,

 

As we could see in the flow run history, you should send the user email instead of the user name.

1.png

Please take a try to send the Sam Choi's mail.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

13 REPLIES 13
Krishna92
Level 8

Re: Status:400 The specified user could not be found

@samsam 

 

I have tried testing the same from my end as well.

I think the problem here is that the People or Group column in share point takes only one value at a time.

If you pass two user values let's say abc@xyz.com and def@xyz.com it is considered as a whole and it tends to read the value as 

'abc@xyz.comdef@xyz.com' because of which it is unable to update.

 

You can check the same behavior in share point as well. Go the people or group column that you have in the list and try adding multiple users in the column manually, once you add a new user it will automatically over ride the old value.

 

I think this is the reason why you are getting the error

 

If this information helps you, please hit the like button and mark the solution as resolved, so that it will help other users in future.

samsam
Level: Powered On

Re: Status:400 The specified user could not be found

@Krishna92 

(sorry, i'm not sure is it correct below....)

It was showing 2 contacts, and only 1 contact has been selected.

The ComboBox field had been disabled the multiple selection

So, it should be only one value in this field... 

 

Q20d.PNG

Krishna92
Level 8

Re: Status:400 The specified user could not be found

@samsam 

 

Yes, I think now you can pass the email address of the user that you are selecting in your combo box to the flow and test.

Hope the CREATE ITEM action will now work perfectly fine with out any issues

 

If this information helps you, please hit the like button and mark the solution as resolved, so that it will help other users in future.

samsam
Level: Powered On

Re: Status:400 The specified user could not be found

@Krishna92 

I have changed the CombxBox to use "Mail" only, and single layout. In the app, it shows 1 record only. 

But it still returns the same error message .... 

 

Q20e.PNGQ20f.PNGQ20g.PNG

Community Support Team
Community Support Team

Re: Status:400 The specified user could not be found

Hi @samsam ,

 

Could you please share a screenshot of the create item action in your flow?

Please make sure the value in the Person Claims column should as screenshot below:

1.png

The type of the value in the Person Claims column should as below:

i:0#.f|membership|UserEmail

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

samsam
Level: Powered On

Re: Status:400 The specified user could not be found

@v-alzhan-msft 

I tried the changes, don't know is it correct. 

And it returns fail

 

Q20h.PNGQ20i.PNGQ20j.PNGQ20k.PNG

samsam
Level: Powered On

Re: Status:400 The specified user could not be found

@v-alzhan-msft 

the original Flow was success if selected Selina Chan. 

But it was failed if selected Sam Choi. 

Would it be an issue as shown below

Q20l.PNG

 

 

Community Support Team
Community Support Team

Re: Status:400 The specified user could not be found

Hi @samsam ,

 

As we could see in the flow run history, you should send the user email instead of the user name.

1.png

Please take a try to send the Sam Choi's mail.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Krishna92
Level 8

Re: Status:400 The specified user could not be found

@samsam 

 

Could you please try adding a OFFICE365USERS - GET USER DETAILS action in flow and check if you are able to retrieve the details related to the user.

 

Also I think form the body response that you have attached I think you are directly passing the user display name not the email address.

 

If you add the email address then the response as below in Body of the Create Item under the people or group column

 

If you add email address of the user only then the People or group function will work and in the body of the action card you will be able the see the email address that you have passed but not the user name.

 

ComboBox1.Selected.Mail --> Please add this to the power app response that you are sending to flow.

 

Also could you please confirm if the user is from the same organization or from a different organization.

The error seems that the flow is unable to detect the user.

 

Could you also try creating a new flow with a manual trigger and create item action and in that in the Request by represent column try manually adding the users email address and test if the flow is able to detect it or not.

 

I think the problem here with the format and it is expecting a email address and the value that is being passed is a name.

 

Hope this information helps

samsam
Level: Powered On

Re: Status:400 The specified user could not be found

@v-alzhan-msft 

Thanks for the help~ when submit by using email address, it works perfectly 😀 

Super User
Super User

Re: Status:400 The specified user could not be found

Hey @samsam 

 

 

 

Does your SharePoint people column allows multiple values?

 

 

Kind regards

 

 

Tom





Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!





samsam
Level: Powered On

Re: Status:400 The specified user could not be found

@Tom_Slosse  it is "No", disabled

Super User
Super User

Re: Status:400 The specified user could not be found

Hey @samsam 

 

 

Then you are only able to save one person in that field and not multiple.

So if you change that I think you will be able to save more than one person to that field with your flow

 

 

Kind regards

 

Tom





Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!





Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (5,014)