cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate II
Advocate II

Status:400 The specified user could not be found

Hi, 

 

I received an error of "Status:400 The specified user could not be found.", when it is in "Create Item" step.
That is a "Person / Group" field in SharePoint's List

 

No error comes up when the ComboBox's field has 1 record only.

However, when the ComboBox's field has 2 or more records, the error comes up

 

I tried below, and result are the same.
Choices('LG013-DataCenterVisitRequestLog'.'Request by Representative')
Office365Users.SearchUser({searchTerm:ComboBox2.SearchText})

 

Anybody can help?

 

Q20a.PNGQ20b.PNGQ20c.PNG

 

Thanks in advance
Sam

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Status:400 The specified user could not be found

Hi @samsam ,

 

As we could see in the flow run history, you should send the user email instead of the user name.

1.png

Please take a try to send the Sam Choi's mail.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

13 REPLIES 13
Highlighted
Microsoft
Microsoft

Re: Status:400 The specified user could not be found

@samsam 

 

I have tried testing the same from my end as well.

I think the problem here is that the People or Group column in share point takes only one value at a time.

If you pass two user values let's say abc@xyz.com and def@xyz.com it is considered as a whole and it tends to read the value as 

'abc@xyz.comdef@xyz.com' because of which it is unable to update.

 

You can check the same behavior in share point as well. Go the people or group column that you have in the list and try adding multiple users in the column manually, once you add a new user it will automatically over ride the old value.

 

I think this is the reason why you are getting the error

 

If this information helps you, please hit the like button and mark the solution as resolved, so that it will help other users in future.

Highlighted
Advocate II
Advocate II

Re: Status:400 The specified user could not be found

@Krishna92 

(sorry, i'm not sure is it correct below....)

It was showing 2 contacts, and only 1 contact has been selected.

The ComboBox field had been disabled the multiple selection

So, it should be only one value in this field... 

 

Q20d.PNG

Highlighted
Microsoft
Microsoft

Re: Status:400 The specified user could not be found

@samsam 

 

Yes, I think now you can pass the email address of the user that you are selecting in your combo box to the flow and test.

Hope the CREATE ITEM action will now work perfectly fine with out any issues

 

If this information helps you, please hit the like button and mark the solution as resolved, so that it will help other users in future.

Highlighted
Advocate II
Advocate II

Re: Status:400 The specified user could not be found

@Krishna92 

I have changed the CombxBox to use "Mail" only, and single layout. In the app, it shows 1 record only. 

But it still returns the same error message .... 

 

Q20e.PNGQ20f.PNGQ20g.PNG

Highlighted
Community Support
Community Support

Re: Status:400 The specified user could not be found

Hi @samsam ,

 

Could you please share a screenshot of the create item action in your flow?

Please make sure the value in the Person Claims column should as screenshot below:

1.png

The type of the value in the Person Claims column should as below:

i:0#.f|membership|UserEmail

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Highlighted
Advocate II
Advocate II

Re: Status:400 The specified user could not be found

@v-alzhan-msft 

I tried the changes, don't know is it correct. 

And it returns fail

 

Q20h.PNGQ20i.PNGQ20j.PNGQ20k.PNG

Highlighted
Advocate II
Advocate II

Re: Status:400 The specified user could not be found

@v-alzhan-msft 

the original Flow was success if selected Selina Chan. 

But it was failed if selected Sam Choi. 

Would it be an issue as shown below

Q20l.PNG

 

 

Highlighted
Community Support
Community Support

Re: Status:400 The specified user could not be found

Hi @samsam ,

 

As we could see in the flow run history, you should send the user email instead of the user name.

1.png

Please take a try to send the Sam Choi's mail.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Microsoft
Microsoft

Re: Status:400 The specified user could not be found

@samsam 

 

Could you please try adding a OFFICE365USERS - GET USER DETAILS action in flow and check if you are able to retrieve the details related to the user.

 

Also I think form the body response that you have attached I think you are directly passing the user display name not the email address.

 

If you add the email address then the response as below in Body of the Create Item under the people or group column

 

If you add email address of the user only then the People or group function will work and in the body of the action card you will be able the see the email address that you have passed but not the user name.

 

ComboBox1.Selected.Mail --> Please add this to the power app response that you are sending to flow.

 

Also could you please confirm if the user is from the same organization or from a different organization.

The error seems that the flow is unable to detect the user.

 

Could you also try creating a new flow with a manual trigger and create item action and in that in the Request by represent column try manually adding the users email address and test if the flow is able to detect it or not.

 

I think the problem here with the format and it is expecting a email address and the value that is being passed is a name.

 

Hope this information helps

Highlighted
Advocate II
Advocate II

Re: Status:400 The specified user could not be found

@v-alzhan-msft 

Thanks for the help~ when submit by using email address, it works perfectly 😀 

Highlighted
Memorable Member
Memorable Member

Re: Status:400 The specified user could not be found

Hey @samsam 

 

 

 

Does your SharePoint people column allows multiple values?

 

 

Kind regards

 

 

Tom



If this reply has answered your question or solved your issue, please mark this question as answered.

Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

Highlighted
Advocate II
Advocate II

Re: Status:400 The specified user could not be found

@Tom_Slosse  it is "No", disabled

Highlighted
Memorable Member
Memorable Member

Re: Status:400 The specified user could not be found

Hey @samsam 

 

 

Then you are only able to save one person in that field and not multiple.

So if you change that I think you will be able to save more than one person to that field with your flow

 

 

Kind regards

 

Tom



If this reply has answered your question or solved your issue, please mark this question as answered.

Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (5,973)