cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kimberlymecham
New Member

SubmissionTime no longer present

I am creating my first Flow using Templates for Track Microsoft Forms responses in an Excel Online (Business) spreadsheet.   I need the date and time of when the user submitted the form.

 

What I observed: 

  1. If I download the Form into excel, there are two fields "Start time" and "Completion time".  Neither of those fields appears to be available in the list of Dynamic content when I create my flow.
  2. Submission Time is available in Dynamic content, but when I add that field, I get a message "'item/SubmissionTime' is no longer present in the operation schema. It should be removed before the workflow is re-saved.

example of submissiontime error.png

2 ACCEPTED SOLUTIONS

Accepted Solutions
JohnAageAnderse
Super User
Super User

Hello @kimberlymecham 

Is that actually an error relating to the dynamic field? I have seen a similar error when a column in the list I am adding to has been removed. Check your Excel file, does the table have the missing column?

Kind regards, John

View solution in original post

manuelstgomes
Super User II
Super User II

Hi @kimberlymecham 

 

Usually, that error occurs when you fetch the structure of the Excel and then remove a field. Power Automate keeps a reference of the "old" column, but since it's not present anymore and has an object associated with it, it keeps it but warns that that column doesn't exist anymore. So if you have a "item/...", it means that you removed it and should remove any insertion in that field since it will fail.

 

Makes sense?

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Cheers
Manuel

View solution in original post

3 REPLIES 3
JohnAageAnderse
Super User
Super User

Hello @kimberlymecham 

Is that actually an error relating to the dynamic field? I have seen a similar error when a column in the list I am adding to has been removed. Check your Excel file, does the table have the missing column?

Kind regards, John

View solution in original post

manuelstgomes
Super User II
Super User II

Hi @kimberlymecham 

 

Usually, that error occurs when you fetch the structure of the Excel and then remove a field. Power Automate keeps a reference of the "old" column, but since it's not present anymore and has an object associated with it, it keeps it but warns that that column doesn't exist anymore. So if you have a "item/...", it means that you removed it and should remove any insertion in that field since it will fail.

 

Makes sense?

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Cheers
Manuel

View solution in original post

Thank you for the responses.  I figured out that even though it was Power Automate who put that Submission field in there for me to fill in, it didn't like it.  I eventually used another field in the spreadsheet and filled it in with the dynamic offering of SubmissionTime (a field that doesn't come through when you download the data from the form) and it worked fine.  It was kind of an accidental find.

Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (52,704)