cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate I
Advocate I

Teams Approval into private channel

Having now got private channels, I am trying to get an approval flow running which uses a private admin channel for the team to manage approvals.  It works fine into a public channel, but as the Team is going to have many guest accounts I dont want them to see the approval cards as they are generated. 

When the step runs in flow I get an error

 
"Request to the Bot framework failed with error: '{\"error\":{\"code\":\"BotNotInConversationRoster\",\"message\":\"The bot is not part of the conversation roster.\"}}'."
Which to me says that the flowbot isn't a member of the private channel and so can't post to it, the connector is authenticated as my account which is a member of the channel.  Can anyone suggest a way round this, ie can I get the flowbot to authenticate as me?
1 ACCEPTED SOLUTION

Accepted Solutions

Hi @Gunjan09 

 

I don't think its possible.  There is a User Voice just started by someone else here ...

 

User Voice 

View solution in original post

4 REPLIES 4
Community Support
Community Support

 

Hi @AndyTuke1 ,

 

Could you please provide the detailed configuration of the Flow?

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-bacao-msft 

 

Hi Barry,

 

Here's a Flow to demonstrate the issue

 

FlowPrivateChannelError.png

 

In the step "Post your own adaptive card as the Flow bot to a channel", if I select the public General channel it works fine.  Using a private channel gives the error

 

Request to the Bot framework failed with error: '{"error":{"code":"BotNotInConversationRoster","message":"The bot is not part of the conversation roster."}}'.

 

The bot obviously isnt a user I can add to the private channel, so even though the connection is made as my user account which is both a Team owner and a member of the private channel it doesnt work.  I have tried the 'Requestor' option without success as well

 

Andy

New Member

Hi @AndyTuke1 ,

 

I have ran into the same problem. Have you found a solution or more information on why this error occurs?

 

Thanks,

Gunjan

Hi @Gunjan09 

 

I don't think its possible.  There is a User Voice just started by someone else here ...

 

User Voice 

View solution in original post

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (6,523)