cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

The caller with object id does not have permission for connection under Api 'shared_sql' and failed during http send request errors

I am creating a simple flow using a service account that has all the correct permissions for both power automate and powerapps and all the relevant data sources.

 

I cannot test this flow in power automate and I cannot add the flow to powerapps. My manager is the only person who can test the flow and add the flow to powerapps.

 

I cannot understand why this is happening as I have had several other view similar flows that are using the service account > data source connection with no issues and have been able to add these to my powerapp with no problems. I understand that this is a permissions issue but I cannot understand where the issue is stemming from as it was working on Monday and suddenly stopped working yesterday. I was hoping that the issue would resove itself if left overnight as many other users have experienced but this doesn't seem to be the case.

 

I've gotten very far in creating this app and all the flows associated so re-creating this app and all flows is not an option.

 

Any help would be much appreciated

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Helper I
Helper I

Re: The caller with object id does not have permission for connection under Api 'shared_sql' and failed during http send request errors

For anyone experiencing the same issue this is what we did to fix the issue.

 

We restarted the gateway which fixed the majority of the connection issues on their own. For those that did not fix with a restart, we went into the connections section:

knives_0-1596527309713.png

Unshared with everyone, including those who have edit permissions, so that only the owner is left and re-shared. Then went back in and re-added people with the correct permissions.

View solution in original post

2 REPLIES 2
Highlighted
Frequent Visitor

Re: The caller with object id does not have permission for connection under Api 'shared_sql' and failed during http send request errors

I have the same issue too, 

All action under SQL Server option always fails. The 'Server Name', 'Database Name', and 'Table Name' input fields always show error 'Could not retrieve values. The caller with object id { objectid } does not have permission for connection { connectionid } under API "shared_sql"'.

 

I have been using power automate since June 2019, and never experienced this before. 


Please fix this error. 

Thanks

Highlighted
Helper I
Helper I

Re: The caller with object id does not have permission for connection under Api 'shared_sql' and failed during http send request errors

For anyone experiencing the same issue this is what we did to fix the issue.

 

We restarted the gateway which fixed the majority of the connection issues on their own. For those that did not fix with a restart, we went into the connections section:

knives_0-1596527309713.png

Unshared with everyone, including those who have edit permissions, so that only the owner is left and re-shared. Then went back in and re-added people with the correct permissions.

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Find your favorite faces from the community presenting at the Power Platform Community Conference!

FirstImage

Microsoft Ignite 2020

Check out the announcement of Power Platform content at Microsoft Ignite!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Users online (8,754)