cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PeeterTi
Regular Visitor

The flow sends only 20 emails out of 30

Hi, 

I've created the flow which takes the list of recipients from the excel and then sends an email with unique attachment.

Everything works, but the issue is that only 20 emails send out of 30 and I not able to understand why. Maybe some of you can help me and find the root cause of this issue.

 

Thanks in advance, 

Peeter 

Screenshot2022-05-21 18_49_02.pngScreenshot2022-05-21 18_49_55.pngScreenshot2022-05-21 18_51_45.png

1 ACCEPTED SOLUTION

Accepted Solutions
CraigStewart
Resolver III
Resolver III

Hi

 

Bad news - the list files in folder is limited to 20 files unfortunately.

 

I created 30 files with your naming convention, tried the list files only got 20 back. So I then added 50 to the threshold to see if it was similar to the restriction with excel lines, but to no avail.

 

CraigStewart_0-1653228249902.png

 

 

Did a bit of digging and found several issues online with people reporting the same thing.

 

There is a post on the ideas forum but it doesn't seem to have any traction which is unfortunate.

https://powerusers.microsoft.com/t5/Power-Automate-Ideas/List-files-in-folder-on-OneDrive-without-li...

 

The work around for your needs would be to move your storage location to elsewhere, maybe a SharePoint document location as this doesn't have the limitation.

 

Craig

 

View solution in original post

14 REPLIES 14
CraigStewart
Resolver III
Resolver III

In your apply to each 2, after the flow is run does it show 30 items?

CraigStewart_0-1653150972706.png

 

If it does then you'll need to go through each one to see if 10 are going down the No path that follows your condition.

 

Hi Craig, 

Thank you for the prompt reply. I'm a beginner in Power Automate, so excuse me if the answer will take a bit longer from my side, as I need to dig into the troubleshooting process. 

I've checked the history of the Flow and found that in the step "List files in folder" the output contains only 20 records. (Screenshot added). It means that Apply for each step will only process 20 records, now I need to understand why it's happening. 

I also checked output for List rows present in a table and it has all 30 records. 

Do you have any ideas what else I can check?

 

Thanks in advance, 

PeeterScreenshot2022-05-22 10_36_11.pngScreenshot2022-05-22 10_54_05.pngScreenshot2022-05-22 10_55_31.png

CraigStewart
Resolver III
Resolver III

Hi

 

Not to worry. I've only been using Power Automate a couple of months myself.

 

Your first apply to each is from list files in folder. Are you expecting 30 files in there?

If so have you possibly set a threshold previously in the settings on that action?

 

Click the 3 dots. Settings and check threshold hasn't been set to 20.

 

On your apply to each 2 if you click through 'Next' you'll probably find that the ones going down the No path on your condition are not finding the match they need. So it seems that the problem lies with the list of files here.

 

Have a look at the settings and let me know. I will have a go a recreating your flow later today if it's still an issue.

Hi Craig, 

 

Appreciate your support, thanks for your prompt replies. Yes, I expect 30 files after List files in folder. Please find the settings of  "List files in folder" step and from "Apply to each". I don't have any Threshold specified. I need to go now, but in the evening today I will try to go though "Next" and see what can be wrong there. I'm also thinking how can I catch value which went under the NO or False statement of IF clause. But you're correct, most probably the issue lies in the list of files in a folder.

 

Br, 

PeeterScreenshot2022-05-22 12_23_02.pngScreenshot2022-05-22 12_23_20.png

CraigStewart
Resolver III
Resolver III

Hi

 

Bad news - the list files in folder is limited to 20 files unfortunately.

 

I created 30 files with your naming convention, tried the list files only got 20 back. So I then added 50 to the threshold to see if it was similar to the restriction with excel lines, but to no avail.

 

CraigStewart_0-1653228249902.png

 

 

Did a bit of digging and found several issues online with people reporting the same thing.

 

There is a post on the ideas forum but it doesn't seem to have any traction which is unfortunate.

https://powerusers.microsoft.com/t5/Power-Automate-Ideas/List-files-in-folder-on-OneDrive-without-li...

 

The work around for your needs would be to move your storage location to elsewhere, maybe a SharePoint document location as this doesn't have the limitation.

 

Craig

 

Hi Craig, 

Thank you for your effort on research and the information you posted - It helped! I went through the link you provided and once I turned the "Pagination" on and set the Threshold limit to 200, I got expected result and have received 30 emails with 30 attachments to my mailbox. So, for me it is solved the issue and I'm not sure is this limit now something what I need to take into account in the future.... Probably this is something what should MS say or maybe it's documented somewhere. Anyway I will mark your answer as accepted solution and will test my Flow with bigger numbers of records in the list.

Thanks for your help.

 

Br, 

Peeter

Screenshot2022-05-22 18_13_49.pngScreenshot2022-05-22 18_16_11.pngScreenshot2022-05-22 18_18_33.pngScreenshot2022-05-22 18_19_02.png

Hi, 

Just for the documentation. I found that the first step only in the flow is successful and the rest steps getting the following error: 

ActionConditionFailed. The execution of template action 'Send_email_(V2)' is skipped: the 'runAfter' condition for action 'Get_file_content' is not satisfied. Expected status values 'Succeeded' and actual value 'Skipped'.

 

But in the end all attachments are sent successfully. Should I ignore this error?

Br, 

Peeter

CraigStewart
Resolver III
Resolver III

Hi Peeter

 

I think we should try figure out where you're error is coming from.

Are both your Apply to Each now showing 30 items?

If you're getting 30 emails and 30 attachments  but you're also seeing an error that is strange.

 

I've just built your flow as shown in your original post along with 30 files and recreation of your excel sheet and ran it twice without an error.

 

Can you post the run history with your apply to each's showing?

 

 

Hi Craig, 

I tested more and now I'm getting corrupted pdf files into my mailbox, also I found that I had some failed connections. Weird thing was that I couldn't fix them in Chrome (It gave blank page), I was able to fix this in Firefox. Therefore I have a feeling that I will just re-create the Flow from the scratch and then test it again. It will take some time as I have other urgent things on my table. I will keep you posted. 

 

Br, 

Peeter

CraigStewart
Resolver III
Resolver III

No worries Peeter, good luck 🙂

Hi Craig, 

 

Couldn't hold back and re-created the flow. All steps went through without any errors. Only Apply to each and Apply to each 2 steps have some issues. The first step have the valid result, but the second is giving ActionConditionFailed. I don't understand what is the issue as I'm receiving correct .pdf file into my mailbox. Can you share your flow history result in Apply to each section, maybe it will help?

 

Br, 

PeeterScreenshot2022-05-22 22_14_28.pngScreenshot2022-05-22 22_14_46.png

CraigStewart
Resolver III
Resolver III

In this test you would only have received one email yes? What you're seeing here is that the 2nd did not meet the condition you have set, so this isn't an error. It's simply that it's going down the NO route - but you aren't doing anything with something that doesn't meet the criteria, so it's not actually an error, your seeing the x because the result was 'false' so nothing happened on that side of the condition.

 

Your condition is that the filename listed in excel matches your display name from file list - double check that they both definitely match.

 

Under the NO section add 2 compose actions, one with the list rows FILE name and one with the list files DISPLAY name.

 

 

 

 

Hi Craig, 

I receive exactly so many email how much emails I have in excel in the column "Email". The issue is seems to be in the two for each loops. "Apply to each" have 30 items and "Apply to each 2" have 2 (Excel column have 2 records for Email).

And now Apply to each loop will match all 30 items against 2 from "Apply to each 2" where success will be on matching 1 -> 1 and 2-> 2. The rest attempts will fail. The result is that I got 2 emails in the very beginning of the started flow and then I just waiting for 40 seconds where those loops will end with errors. Few screenshots also added to better explain the issue. Basically I have more files on OneDrive than in my excel and this is a problem. I need to think how to check only those records and files which existing in the excel?

Thanks for your effort, at lest we know now that it's not a bug, but feature 🙂

Br 

PeeterScreenshot2022-05-22 22_45_04.pngScreenshot2022-05-22 22_46_03.pngScreenshot2022-05-22 22_46_49.pngScreenshot2022-05-22 22_47_18.png

 

CraigStewart
Resolver III
Resolver III

Ah ok I see.

 

It's not actually an issue - it just makes results difficult to read.

 

So your excel currently has 2 lines

Your folder has 30 files

 

Either way you do this, through the excel first of via the folder list your flow will continue to have these inactions showing as going through the NO

 

As your screenshots show the first file shows a positive from 1/30 apply to each in 1/2 in apply to each 2

2nd file is a NO coming from 2/30 and hitting 1/2, BUT its a yes against 2/2

If there was a 3rd line in excel you'd see the condition hitting NO on 1/30 & 2/30, but then yes on 3/30 and so on where each line would only be shown positive on the number that matches the line 4/30, 5/30, 6/30 with the rest going through the NO.

 

I rebuilt the flow to see if using excel first then onedrive made any difference but it still would have the same results, it is going to go through all the files and all the lines to find a match.

 

You're getting the correct results and I assume your flow is finishing as Succeeded, so technically there isn't anything to worry about and the flow is working as expected.

 

I'm wondering if there is a cleaner way to do this - so I'll have a think. But for now you're good to go.

 

 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (1,831)