cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
stapes
Post Prodigy
Post Prodigy

There is a problem with the flow's trigger. BadRequest.

This flow has been running successfully, as the picture shows, but is now showing this error:

showing error while runs are succeeding..PNG

Followed the 'Fix the trigger link', and under schema, it is showing this:

 

 

{
  "type": "object",
  "properties": {
    "varBatchDetailID_Value": {
      "type": "integer",
      "description": "Enter initial value",
      "x-ms-powerflows-param-ispartial": false
    },
    "varDeliveryID_Value": {
      "type": "integer",
      "description": "Enter initial value",
      "x-ms-powerflows-param-ispartial": false
    },
    "varFlCaseSize_Value": {
      "type": "number",
      "description": "Enter initial value",
      "x-ms-powerflows-param-ispartial": false
    },
    "varFlQuantity_Value": {
      "type": "number",
      "description": "Enter initial value",
      "x-ms-powerflows-param-ispartial": false
    },
    "varFlProductTemp_Value": {
      "type": "number",
      "description": "Enter initial value",
      "x-ms-powerflows-param-ispartial": false
    },
    "varStBatchCode_Value": {
      "type": "string",
      "description": "Enter initial value",
      "x-ms-powerflows-param-ispartial": false
    },
    "varUseByDate_Value": {
      "type": "string",
      "description": "Enter initial value",
      "x-ms-powerflows-param-ispartial": false
    },
    "varBlPrinted_Value": {
      "type": "boolean",
      "description": "Enter initial value",
      "x-ms-powerflows-param-ispartial": false
    },
    "varIntPrintQuantity_Value": {
      "type": "integer",
      "description": "Enter initial value",
      "x-ms-powerflows-param-ispartial": false
    },
    "varStUserName_Value": {
      "type": "string",
      "description": "Enter initial value",
      "x-ms-powerflows-param-ispartial": false
    },
    "varIntControlSheetId_Value": {
      "type": "integer",
      "description": "Enter initial value",
      "x-ms-powerflows-param-ispartial": false
    },
    "varBlUseByNA_Value": {
      "type": "boolean",
      "description": "Enter initial value",
      "x-ms-powerflows-param-ispartial": false
    },
    "varBlPrintedPalletLabel_Value": {
      "type": "boolean",
      "description": "Enter initial value",
      "x-ms-powerflows-param-ispartial": false
    },
    "varIntPalletLabelQty_Value": {
      "type": "integer",
      "description": "Enter initial value",
      "x-ms-powerflows-param-ispartial": false
    }
  },
  "required": [
    "varBatchDetailID_Value",
    "varDeliveryID_Value",
    "varFlCaseSize_Value",
    "varFlQuantity_Value",
    "varFlProductTemp_Value",
    "varStBatchCode_Value",
    "varUseByDate_Value",
    "varBlPrinted_Value",
    "varIntPrintQuantity_Value",
    "varStUserName_Value",
    "varIntControlSheetId_Value",
    "varBlUseByNA_Value",
    "varBlPrintedPalletLabel_Value",
    "varIntPalletLabelQty_Value"
  ]
}

 

 

This is clearly all the Initialised variables, but what is it saying? Why has this suddenly occurred and how can I fix it?

 

Update:

 

Minutes later, this flow runs OK, with no changes, so the Flow is not at fault! It was probably called with a missing parameter.

1 ACCEPTED SOLUTION

Accepted Solutions
CFernandes
Super User III
Super User III

@stapes 

 

Hey Mate,

 

I assume you flow works correctly? If yes there is a Known Issue -  Currently the banner may continue to be displayed even when the next trigger event is successfully executed. The product team is working toward resolving the issue. If your flow continues to run successfully even while the banner is present, then you may be encountering this issue.

 

For details see: https://support.microsoft.com/en-in/help/4540228/there-is-a-problem-with-the-flow-s-trigger 

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

1 REPLY 1
CFernandes
Super User III
Super User III

@stapes 

 

Hey Mate,

 

I assume you flow works correctly? If yes there is a Known Issue -  Currently the banner may continue to be displayed even when the next trigger event is successfully executed. The product team is working toward resolving the issue. If your flow continues to run successfully even while the banner is present, then you may be encountering this issue.

 

For details see: https://support.microsoft.com/en-in/help/4540228/there-is-a-problem-with-the-flow-s-trigger 

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Users online (2,935)