cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
_O365_
Advocate I
Advocate I

There's a problem with the flow's trigger. Error code 502

Hi everyone,

I have created a flow for shared mailbox, which triggers when email from specific sender is received, but get this error:

 code: 502,
 source: "flow-apim-europe-001-francecentral-01.azure-apim.net",
 message: "BadGateway",
 innerError:
status: 502,
message: "Request failed. Try again later.\r\nclientRequestId: e1c96be2-581c-4324-8834-6a761425f4f7",
source: "office365-we.azconn-we-01.p.azurewebsites.net"
 
Any ideas what is wrong? Thank You in advance! 
 
1 ACCEPTED SOLUTION

Accepted Solutions
yashag2255
Dual Super User II
Dual Super User II

Hey @_O365_ 

 

Glad that you were able to resolve. If this issue is resolved, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

4 REPLIES 4
manuelstgomes
Super User II
Super User II

hi @_O365_ 

 

It could be something in Azure acting up but should be temporary. Are you still getting the error?

 

Can you try something? Just go to the Connections and re-connect to the shared mailbox. Sometimes something changes and invalidates the connection. The connection in the "Connections" tab looks ok, but it isn't.

 

small-Screenshot_2019-10-17_at_10_13_33.jpg

 

Can you please let me know if this worked? If not, can you share the step of the flow that fails so that I can try to understand what can be wrong?

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Cheers
Manuel

yashag2255
Dual Super User II
Dual Super User II

Hey @_O365_ 

 

Can you share a screenshot of the flow? Can you click on the ... in the trigger and go to Peek Code and check what is the value for recurrence key in that trigger? (If it is a negative value, I would recommend to create a support ticket)

 

If this flow was started from a template or created as a copy, I recommend deleting the trigger and add it again and check if you continue to face the same issues. 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

_O365_
Advocate I
Advocate I

Thanks for help guys! It is fixed. I guess something was wrong in Azure.

yashag2255
Dual Super User II
Dual Super User II

Hey @_O365_ 

 

Glad that you were able to resolve. If this issue is resolved, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (68,835)