cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate I
Advocate I

Tracking working time and location template

Hello,

 

I've been using the template for tracking working time and location for a few weeks, and it was working fine, except for a few bugs that happened when I was connected to the wifi, but it's been failing for a few days now on an error saying:

 

"Unable to process template language expressions in action 'Insert_row' inputs at line '1' and column '1536': 'The template language expression 'triggerBody()['location']['fullAddress']' cannot be evaluated because property 'location' doesn't exist, available properties are 'user, key-button-timestamp, key-button-date'. Please see https://aka.ms/logicexpressions for usage details.'."

 

Has anyone come across with this error? Help?

Thanks,

Camila.

    

7 REPLIES 7
Community Support
Community Support

Hi @cdesavio,

 

I have reproduced your issue and got exactly the same error in Insert Row action. I will report this to the product team. Thanks for your noticing.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks, Mona.

Hi @cdesavio,

 

I just got the update from pg that there was a known regression related with location API key that mobile team is fixing. But do not have a timeline yet.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Wow, it takes them to fix it for months already, since the issue is still there

New Member

February 2019 and it's still not fixed. Flows with location work fine on a Windows laptop but whether they work on iOS or Android phone seems to be a matter of luck. I use a flow to push a notification with my current location and another to log time and location I start and end work (I have to travel around and do crazy hours). Both work fine on my work laptop (Windows). Push location initially worked in iOS phone app (but not widget) while log location did not work in iOS app or widget. Both flows initially worked in Android phone app (but not widget). Now push location stopped working in iOS phone app but still works in Android phone app. The error message is always the same: "...because property 'location' doesn't exist,...". I tried using template flows and ones I created myself - same story. I don't believe Microsoft cannot fix it, which makes me think they can't be bothered. 

Hi,

 

do you have solution for this case? For me it works when I use template which has location info, but when I create new flow it doesn't finish successfully. 

 

Br,

Renato. 

New Member

I just got this problem today. 
Anyone has any update or workaround?

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (71,402)