cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Trying to put TypeForm timestamp in an Excel table

I mapped the "Submitted date-time" and "Sent date-time" fields from a TypeForm form to columns in an Excel table. Both columns are blank following any form submission. All the user entered fields populate as expected.

 

Does anyone know why this is not working for me?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Power Automate
Power Automate

Re: Trying to put TypeForm timestamp in an Excel table

Hi @TheRydad - are you seeing the datetime values in the output of the TypeForm operation? A quick way to check is on the flow run itself, you can see the values that are outputted before they're passed to the Excel file. That will help narrow down whether there's an issue in the TypeForm operation or the Excel one. If you could share those detials in a direct message to me, that would be great!

View solution in original post

5 REPLIES 5
Highlighted
Power Automate
Power Automate

Re: Trying to put TypeForm timestamp in an Excel table

Hi @TheRydad - are you seeing the datetime values in the output of the TypeForm operation? A quick way to check is on the flow run itself, you can see the values that are outputted before they're passed to the Excel file. That will help narrow down whether there's an issue in the TypeForm operation or the Excel one. If you could share those detials in a direct message to me, that would be great!

View solution in original post

Highlighted
Advocate I
Advocate I

Re: Trying to put TypeForm timestamp in an Excel table

Thank you! I did not realize I could view the details of the steps in the flow.

 

Typeform is sending blank values for those fields. I will check on their side to see how it is supposed to work.

Highlighted
Advocate I
Advocate I

Re: Trying to put TypeForm timestamp in an Excel table

Checking the flow run, the datetime values from TypeForm are not being sent. To test further, I created another flow to just create a file in OneDrive with those vlues. It, too, turns up empty for those values.

 

I manually connected to my TypeForm API in a web browser, and the datetime values "date_land" and "date_submit" are present for each entry I have made.

 

Is it possible that there is a bug in the TypeForm trigger and it is not mapping those fields correctly?

 

As a workaround, is there a way to get a timestamp value from when the flow itself runs? I only need the day, so the precise timestamp is not important to me.

 

Thank you.

Highlighted
Power Automate
Power Automate

Re: Trying to put TypeForm timestamp in an Excel table

@TheRydad - thanks for the details! We have reproduced the issue on our side and are investigating why the connector isn't returning the value that's coming back from TypeFrom.

 

There isn't a way to get the "current" time in a flow today (although please add it to our ideas page) - the closest option would be to add another action (such as "create a task" in Google, Todoist etc.) immediately after and use the time output from that. That would purely be a workaround but might unblock you while we investigate the bug!

Highlighted
Advocate I
Advocate I

Re: Trying to put TypeForm timestamp in an Excel table

Thanks for verifying. This isn't a showstopping production issue for me now, but it is nice to validate the issue.

 

I might try one of your clever workarounds if this becomes more critical. I will also add the suggestion.

 

-r

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (7,037)