cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper III
Helper III

Trying to use Send an HTTP request to SharePoint getting a Bad Request error , "Microsoft.SharePoint.Client.InvalidClientQueryException"

Trying to use Send an HTTP request to SharePoint getting a Bad Request error , "Microsoft.SharePoint.Client.InvalidClientQueryException"

post.jpgerror.jpg

 

 

4 REPLIES 4
Highlighted
Community Support
Community Support

Re: Trying to use Send an HTTP request to SharePoint getting a Bad Request error , "Microsoft.SharePoint.Client.InvalidClientQueryException"

Hi @Yemata ,

 

It seems that you missed one more “_” before “metadata”.

 

I have set up the action likes below, which is working properly.

1.PNG

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper III
Helper III

Re: Trying to use Send an HTTP request to SharePoint getting a Bad Request error , "Microsoft.SharePoint.Client.InvalidClientQueryException"

@v-yamao-msft Hi Mable ,

 

Thank you for the swift reply as usual 🙂 . I checked the "_" and i have two , below here the whoe body. 

{
"__metadata":{
"type":"SP.Data.DocumentsListItem"
},
"Title2":{
"__metadata":{
"type":"SP.FieldUrlValue"
},
"Description":"TestABC",
"Url":"https://www.google.com"
}
}

 

Thank you.

Highlighted
Helper III
Helper III

Re: Trying to use Send an HTTP request to SharePoint getting a Bad Request error , "Microsoft.SharePoint.Client.InvalidClientQueryException"

@v-yamao-msft  Any suggestion ? 

Highlighted
Community Support
Community Support

Re: Trying to use Send an HTTP request to SharePoint getting a Bad Request error , "Microsoft.SharePoint.Client.InvalidClientQueryException"

Hi @Yemata ,

 

Please check the following blog for a reference:

https://veenstra.me.uk/2018/10/03/microsoft-flow-update-a-hyperlink-or-picture-field/

 

I am still working on figuring out a solution for your issue.

 

Hope this doc would also be helpful:

https://docs.microsoft.com/en-us/sharepoint/dev/sp-add-ins/working-with-folders-and-files-with-rest

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (9,606)