cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SK_Tan
Helper III
Helper III

Unable to process template language expressions in action 'Parse_JSON_2' inputs at line '1' and column '30004': 'Required property 'content' expects a value but got null. Path ''.'.

Hi,

 

I built a flow to add attachment in MS. Forms to SharePoint. One of the attachments is "not mandatory" and hence might not have attachment some time. In the occasion where no attachment is added, my flow failed. See below for more details:

 

SK_Tan_0-1637204651340.png

 

Dows anyone can share how to tackle this?

 

Thanks in advance!

 

1 ACCEPTED SOLUTION

Accepted Solutions
Gopala_Krishna
Super User
Super User

@SK_Tan 

You can try adding a condition before the "Parse JSON 2" action to check for the null values, in the yes part of the condition you can leave as it is and in the no part of the condition you can add the "Parse JSON 2" and the next actions after that.

 

Once you do this change, I don't think you will see any issue with the Parse JSON 2 action.

 

 

If the information shared helps you please consider giving a thumbs up 👍 and mark solution as resolved

Please follow my website PowerCards for more information related to Power Platform

View solution in original post

5 REPLIES 5
Gopala_Krishna
Super User
Super User

@SK_Tan 

You can try adding a condition before the "Parse JSON 2" action to check for the null values, in the yes part of the condition you can leave as it is and in the no part of the condition you can add the "Parse JSON 2" and the next actions after that.

 

Once you do this change, I don't think you will see any issue with the Parse JSON 2 action.

 

 

If the information shared helps you please consider giving a thumbs up 👍 and mark solution as resolved

Please follow my website PowerCards for more information related to Power Platform

Thank you for your response.

 

I followed and still the same error.

 

SK_Tan_0-1637218736953.png

 

Something wrong with the value I used?

Did you find a solution? I have the same problem, checking for a null variable does not solve it. 

gonzaloramos
New Member

try to eliminate de "null" function. I let the field empty and it works.

Indeed just check for an empty field. 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power Automate Designer Feedback_carousel.jpg

Help make Flow Design easier

Are you new to designing flows? What is your biggest struggle with Power Automate Designer? Help us make it more user friendly!

Users online (2,030)