cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Unable to read list that has a lookup field

I'm trying to run a Flow on an on-premise SharePoint Site.  The On-premise data gateway is running and I created a connection to it.  I am also able to successfully run Flow on a list that does not contain a lookup field to another list.

 

My probem is when the list contains a lookup field to another list on the same SharePoint site, I get a 'BadRequest' error.  Status code is 400

 

The body of the output is:

{
  "status"400,
  "message""The field 'Facility' is not supported in query. The lookup list does not exist.\r\nclientRequestId: 77a48c5b-681f-4c9d-adde-87fc6ee117b4\r\nserviceRequestId: df31829e-94eb-f03a-9712-1f8d7aab0173;df31829e-64f3-f03a-9712-1275f26f90c8;e031829e-f406-f03a-9712-1fbbed50d9df;e031829e-b40f-f03a-9712-1a5d0f7d12c2;e031829e-8418-f03a-9712-1aba8e301699;e031829e-5420-f03a-9712-14c03c1b4500",
  "source""",
  "errors": [
    "-1",
    "Microsoft.SharePoint.SPException"
  ]
}

 

Has anybody else come across this?

4 REPLIES 4
Highlighted
Community Support
Community Support

Re: Unable to read list that has a lookup field

Hi @eshen,

 

Could you share a screenshot of your flow? how is it created?

 

Besides, error 400 means a setting in an action of the flow doesn’t function as expected, you may need to correct the problem inside the flow definition. Please try to update the flow or Resubmit to try the run again with the updated configuration.

 

I don’t have on-Premise SharePoint to test this issue, so I made a simple test with SharePoint Online and it didn’t return any error message. If you also SharePoint Online, please make a simple test on your side to see if it will work.

 

 

Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Unable to read list that has a lookup field

Here's the screenshot. Nothing overly complicated. "Facility" is a lookup field to another list on the same SharePoint site.

I was able to successfully run a flow on a list with a lookup on another on-premise site. So I'm thinking there's something different about the setup of this on-premise server. I think some configuration settings needs to be modified but don't know which one.
Highlighted
Advocate V
Advocate V

Re: Unable to read list that has a lookup field

Hi @eshen,

 

the screen shot is not visible.

 

Regards,

Chandrashekhar

Highlighted
Frequent Visitor

Re: Unable to read list that has a lookup field

Strange.  I am able to see the image even in Incognito on Chrome.   Let me try it this way...

Capture.PNG

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (7,221)