cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ChrisRoxor
Level: Powered On

Using "Trim" expression with Dynamic Content

Hi

 

I'm having some issues using Flow and Microsoft Forms.

I have a form to collect feedback on an Application ID. This feedback is then passed to a Sharepoint list.

That triggers another flow that has a filter array between the Feedback list and the Master list, where i want to submit the feedback to as well.

The issue is, using Forms, people sometimes include a blank space at the end of the applicationID, which in turns, returns blank from the Filter Array.

I tried to add an expression upon the write from Forms to Sharepoint but it's giving me an error:

 

Right now it just fills it straight in:

@{body('Get_response_details')['rb4e2f716f3db4692aa8022940b704a99']}

 

This is my expression, within one of the fields in a "Create Item" Sharepoint action:

trim(@{body('Get_response_details')['rb4e2f716f3db4692aa8022940b704a99']})
but when i click "OK" it gives me an error saying "The expression is invalid".
 
What am I doing wrong here? Can i not trim whitespace from a dynamic content field?
 
Thanks in advance
1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: Using "Trim" expression with Dynamic Content

hi @ChrisRoxor , thank you for posting this.

Try expression:

trim(body('Get_response_details')['rb4e2f716f3db4692aa8022940b704a99'])

I would expect this is correct format as @{} will not make valid WDL.

 

If you find my posts helpful, please mark with thumbs up

If this solves your issue, please click "Accept as Solution"

Any questions, just ask.

Thanks, Alan


Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!


View solution in original post

1 REPLY 1
Super User
Super User

Re: Using "Trim" expression with Dynamic Content

hi @ChrisRoxor , thank you for posting this.

Try expression:

trim(body('Get_response_details')['rb4e2f716f3db4692aa8022940b704a99'])

I would expect this is correct format as @{} will not make valid WDL.

 

If you find my posts helpful, please mark with thumbs up

If this solves your issue, please click "Accept as Solution"

Any questions, just ask.

Thanks, Alan


Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!


View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (2,177)