cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
mboonie
Level 8

View selected in Update Item missing many fields

Hi. I haven't seen this issue yet, but it's a show-stopper!

 

I've built dozens of flows that update a SharePoint list item, and usually I select a specific view for the Update item action. Today, however, a critical view that I created (which includes all of the required fields and others needed for this flow) only shows a handful of fields. I have used this specific view many times, but it has never done this. In fact, if I edit the other "Update item" actions elsewhere in the flow by switching to a different view and then back to this view, THEY are missing fields, too. These aren't things like calculated columns or lookups; but they DO seem to include ALL of the required fields (almost all of which are SLT fields) pluse a handful more.

 

Is there or has there been an update to this action, or is there a know issue that has recently cropped up? Below is a screen capture of the view definition and, below that, the list of fields that appear when I select that view:

 

ViewDefinition.pngViewShownInFlow.png

2 REPLIES 2
Community Support Team
Community Support Team

Re: View selected in Update Item missing many fields

 

Hi @mboonie ,

 

As far as I know, MS Flow has not released any updates about the SharePoint connector recently.

Have you tried updating the connection or recreating a similar Flow?

Sometimes some fields are not displayed properly due to the status of the connection.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
mboonie
Level 8

Re: View selected in Update Item missing many fields

Thanks, but I have tried those things. I've tried all other views for that list, too, and they show the same problem: the fields in the Update Item view bear almost no correlation to the columns actually included in the view.

I've created other, short "test" workflows, and the same exact thing happens. 

Other odd behaviors are also consistent:

  • If I don't select ANY views, I seem to see ALL of the fields (about 110 of them) in the Update Item action.
  • If I select ANY view, I get what looks to be a very-similar-but-not-exactly-the-same very small subset of columns to work with.
  • Trying to go back by choosing "Use all columns..." brings back all columns except the required ones!
  • I'm not getting any actual errors (I don't have more than 12 lookup columns; I have about 7 People columns)

I'm not really comfortable with this sudden change in behavior, even though I don't get errors.

 

Helpful resources

Announcements
firstImage

Power Platform Online Conference

Speakers, submit your sessions now! Call for speakers ends Feb. 10!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (5,206)