cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Resolver I
Resolver I

View selected in Update Item missing many fields

Hi. I haven't seen this issue yet, but it's a show-stopper!

 

I've built dozens of flows that update a SharePoint list item, and usually I select a specific view for the Update item action. Today, however, a critical view that I created (which includes all of the required fields and others needed for this flow) only shows a handful of fields. I have used this specific view many times, but it has never done this. In fact, if I edit the other "Update item" actions elsewhere in the flow by switching to a different view and then back to this view, THEY are missing fields, too. These aren't things like calculated columns or lookups; but they DO seem to include ALL of the required fields (almost all of which are SLT fields) pluse a handful more.

 

Is there or has there been an update to this action, or is there a know issue that has recently cropped up? Below is a screen capture of the view definition and, below that, the list of fields that appear when I select that view:

 

ViewDefinition.pngViewShownInFlow.png

2 REPLIES 2
Community Support
Community Support

 

Hi @mboonie ,

 

As far as I know, MS Flow has not released any updates about the SharePoint connector recently.

Have you tried updating the connection or recreating a similar Flow?

Sometimes some fields are not displayed properly due to the status of the connection.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks, but I have tried those things. I've tried all other views for that list, too, and they show the same problem: the fields in the Update Item view bear almost no correlation to the columns actually included in the view.

I've created other, short "test" workflows, and the same exact thing happens. 

Other odd behaviors are also consistent:

  • If I don't select ANY views, I seem to see ALL of the fields (about 110 of them) in the Update Item action.
  • If I select ANY view, I get what looks to be a very-similar-but-not-exactly-the-same very small subset of columns to work with.
  • Trying to go back by choosing "Use all columns..." brings back all columns except the required ones!
  • I'm not getting any actual errors (I don't have more than 12 lookup columns; I have about 7 People columns)

I'm not really comfortable with this sudden change in behavior, even though I don't get errors.

 

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Microsoft Ignite

Microsoft Power Platform: 2021 Release Wave 1 Plan

Power Platform release plan for the 2021 release wave 1 describes all new features releasing from April through September 2021.

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (25,010)