cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anjali1
Frequent Visitor

Web UI Flow return prompt disappears when triggered through Flow

Hi,

I need to take input from the user via a return prompt in my UI Flow. This seems to work fine when I run the UI Flow individually and the prompt remains on the screen till I enter a value and click 'OK' or 'cancel'. 

 

However when I try to use this UI Flow in a Flow and run the Flow, the prompt disappears within one second and the code breaks.  I have tried adding a pause of 10 seconds after the prompt as a workaround but the prompt still disappears and there is a pause of 10 seconds before the next action is performed by the bot.

 

Is there a method by which I can make the prompt remain onscreen till a value is entered?

Thank you

5 REPLIES 5
abm
Super User
Super User

Hi @Anjali1 

 

Could you please post a screenshot of your input parameter? Generally when its mandatory its should wait till it gets entered. Please make sure the input parameter is mandatory?

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
Anjali1
Frequent Visitor

Hi @abm 

 

It is the captcha on a website that I am prompting the user to enter. It is stored in a variable and the value of the variable is then entered on the web page field for captcha. How do I make the input parameter mandatory ?

 

Thanks

Hi @Anjali1 

 

I am not sure you could do that. Not sure UI Flows can't be interrupted when it start running. That's my understanding.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
Anjali1
Frequent Visitor

Hi @abm 

 

I had used the execute script command for input prompt. While running the UI flow directly, it works fine. The prompt remains on the screen till I enter an input. However it is when I use this in a flow and run it, the prompt disappears immediately, not giving the user enough time to enter the captcha on the prompt.

 

Thanks

Hi @Anjali1 

 

Thanks for your reply. I am not sure how to achieve this. Hopefully someone could help you on this.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

New Process Advisor Capabilities carousel.png

Read the blog for the latest news

Read the latest about new experiences and capabilities in the Power Automate product blog.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

PA Survey Carousel Image.png

We want to hear from you!

If you are a small business ISV/Reseller, share your thoughts with our research team.

Users online (1,991)