cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

What is wrong in this formula?

@equals(ticks(startOfDay(body('Current_time'))), ticks(startOfDay(item()?['Kritische_x0020_vernieuwing'])))

 

I get a fault message after running the flow. What is wrong about this formula?

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Hi @Ochies,

 

How is your flow created? Could you share a screenshot of your flow?

It seems that there is something wrong with your second part of Kritische_x0020_vernieuwing. From which action do you get the dynamic content?

I have made the following flow for testing. Please check it for a reference.

When an item is created, trigger the flow, then get current datetime. If the ticks of current time is equals to ticks of the startDate in the list, send me a mobile notification.

The code in the Condition is:

@equals(ticks(startOfDay(body('Current_time'))), ticks(startOfDay(triggerBody()?['StartDate'])))

Image for your reference:

1.PNG

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Community Support
Community Support

Hi @Ochies,

 

How is your flow created? Could you share a screenshot of your flow?

It seems that there is something wrong with your second part of Kritische_x0020_vernieuwing. From which action do you get the dynamic content?

I have made the following flow for testing. Please check it for a reference.

When an item is created, trigger the flow, then get current datetime. If the ticks of current time is equals to ticks of the startDate in the list, send me a mobile notification.

The code in the Condition is:

@equals(ticks(startOfDay(body('Current_time'))), ticks(startOfDay(triggerBody()?['StartDate'])))

Image for your reference:

1.PNG

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hi Mabel,

 

The flow is working. I made a new list in Sharepoint with a column named 'Startdate' . I put a few items in it, one of the items with the date of today. Then i tried the flow and it works! Probably something is wrong with the first list. Thanks for your help!

Administrator
Administrator

Hey, @Ochies!

Thank you for posting to the Flow Community Forum! It appears you have found a solution to your issue! If you feel as though your issue has been solved and you are satisfied with one of the previous replies, please click "Accept as Solution" on the reply that contains the solution so that this thread will be marked for other users to easily identify!

Thank you for being an active member of the Flow Community!

-Gabriel
Microsoft Flow Community Manager

- Gabriel
Community Manager
Power Automate | Power Virtual Agents
Super User Program Manager
Power Platform Communities

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (3,936)