cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Ochies
New Member

What is wrong in this formula?

@equals(ticks(startOfDay(body('Current_time'))), ticks(startOfDay(item()?['Kritische_x0020_vernieuwing'])))

 

I get a fault message after running the flow. What is wrong about this formula?

1 ACCEPTED SOLUTION

Accepted Solutions
v-yamao-msft
Community Support
Community Support

Hi @Ochies,

 

How is your flow created? Could you share a screenshot of your flow?

It seems that there is something wrong with your second part of Kritische_x0020_vernieuwing. From which action do you get the dynamic content?

I have made the following flow for testing. Please check it for a reference.

When an item is created, trigger the flow, then get current datetime. If the ticks of current time is equals to ticks of the startDate in the list, send me a mobile notification.

The code in the Condition is:

@equals(ticks(startOfDay(body('Current_time'))), ticks(startOfDay(triggerBody()?['StartDate'])))

Image for your reference:

1.PNG

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
v-yamao-msft
Community Support
Community Support

Hi @Ochies,

 

How is your flow created? Could you share a screenshot of your flow?

It seems that there is something wrong with your second part of Kritische_x0020_vernieuwing. From which action do you get the dynamic content?

I have made the following flow for testing. Please check it for a reference.

When an item is created, trigger the flow, then get current datetime. If the ticks of current time is equals to ticks of the startDate in the list, send me a mobile notification.

The code in the Condition is:

@equals(ticks(startOfDay(body('Current_time'))), ticks(startOfDay(triggerBody()?['StartDate'])))

Image for your reference:

1.PNG

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hi Mabel,

 

The flow is working. I made a new list in Sharepoint with a column named 'Startdate' . I put a few items in it, one of the items with the date of today. Then i tried the flow and it works! Probably something is wrong with the first list. Thanks for your help!

GabrielStJohn
Administrator
Administrator

Hey, @Ochies!

Thank you for posting to the Flow Community Forum! It appears you have found a solution to your issue! If you feel as though your issue has been solved and you are satisfied with one of the previous replies, please click "Accept as Solution" on the reply that contains the solution so that this thread will be marked for other users to easily identify!

Thank you for being an active member of the Flow Community!

-Gabriel
Microsoft Flow Community Manager

- Gabriel
Community Manager
Power Automate | Power Virtual Agents
Super User Program Manager



Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (44,907)