cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
erikah
Level: Powered On

When Sharepoint Item Created Trigger

I am moving one Sharepoint list item to a new list with the attachments. Everything was working great but then I realized that it was recreating items that were already on the list. So, it wasn't just creating when a new item is created. I tried adding a condition that Created does not equal Modified but that didn't work, so I deleted it. Any advice on next steps? Thank you!

flow.pngflow1.pngflow2.png

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: When Sharepoint Item Created Trigger

Hi @erikah your first actions should be Get item not Get items. Get items brings back all the items in the list, whereas you only want to bring back the one item that has just been created, which you get from the ID (see the image below) and then do actions on it.

Rob
Los Gallardos
If I've answered your question or solved your problem, please mark this question as answered. This helps others who have the same question find a solution quickly via the forum search. If you liked my response, please consider giving it a thumbs up. Thanks.

get_item.png

View solution in original post

3 REPLIES 3
Super User
Super User

Re: When Sharepoint Item Created Trigger

Hi @erikah your first actions should be Get item not Get items. Get items brings back all the items in the list, whereas you only want to bring back the one item that has just been created, which you get from the ID (see the image below) and then do actions on it.

Rob
Los Gallardos
If I've answered your question or solved your problem, please mark this question as answered. This helps others who have the same question find a solution quickly via the forum search. If you liked my response, please consider giving it a thumbs up. Thanks.

get_item.png

View solution in original post

erikah
Level: Powered On

Re: When Sharepoint Item Created Trigger

@RobElliott 

THIS! Ok, my only question for you is, when I add my Apply To step, the value isn't populating in Dynamic Content. I know it has to be value. But it won't populate. Ideas?

Super User
Super User

Re: When Sharepoint Item Created Trigger

I'm not selecting "value" from dynamic content but "Attachments" from the Get email (V2) section of dynamic content.

Rob
Los Gallardos
If I've answered your question or solved your problem, please mark this question as answered. This helps others who have the same question find a solution quickly via the forum search. If you liked my response, please consider giving it a thumbs up. Thanks.

get_item2.png

Helpful resources

Announcements
firstImage

Incoming: New and improved badges!

Look out for new contribution recognition badges coming SOON!

firstImage

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Users online (5,321)