cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
anabananei
Resolver I
Resolver I

When an email arrives not triggering flow

Hello,

 

I created a flow that when an email arrives, it gets recorded in a SharePoint list. I created a folder in my Outlook email and created a rule that certain emails will be stored in that folder. It will only pull data from the folder that I created with the subject line that starts with "Pub". It was a success as we did some tests until today. The flow does not trigger for emails sent by one specific user even though all conditions were met. Other than his emails, everything is being recorded. The subject line was correct. It went to the certain folder that I created. Every email received by that folder went through the SharePoint list except from that specific person. Is there a way to fix or at least figure out what went wrong? 

 

Thanks,

Ana

6 REPLIES 6
v-yamao-msft
Community Support
Community Support

Hi @anabananei,

 

Could you share a screenshot of your flow configuration? It seems that you are using email subject filter. You said that the email from one specific user won’t trigger the flow, have you set From field with particular value?

 

I have made a simple test on my side, whenever the conditions are met, the flow would be triggered. Please share more details to help reproduce this issue on my side.

 

 

Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
chandrashekhar
Advocate V
Advocate V

Hi @anabananei,

 

1. What is the subject line of mail from this particular user?  does is contain "Pub"?

 

2. Is this an external user not configured in the active directory or domain?

 

PLease share more details

 

Regards,

Chandrashekhar

Pune, India.

Hello @v-yamao-msft@chandrashekhar:

 

All users are within the organization's database. So I'm not sure why this happened. 

 

We tested 3 types of sending the email. via Reply, Reply to All, Forward and used the subject line that follows the condition (i.e. removing RE: and FW: in the beginning of the subject). The flow was triggered two times and the email was recorded in the SharePoint list twice. Meaning the flow triggered if the email was sent as "Reply/Reply to All". However if the certain user sends it as "New" or "Forward" email, the flow does not trigger. 

 

Here is the screenshot of the my flow.

 

Appreciate your input.

Ana

pt1.jpgpt2.jpg

Hi @anabananei,

 

A small observation from my side:

 

1. When you click on "Reply/Reply to All", there is user present in "To" section.

2. When you click on "New" or "Forward"  there is no email/user taken automatically in "To" section.

 

This may cause the flow to fail. please check the flow history for analysis to check if it fails.

 

Please verify this may be the reason, i am not sure though.

 

Regard,

Chandrashekhar Kumawat

Pune, India.

Hi @chandrashekhar

 

I would love to check but the items not being recorded to the SharePoint list is not also in the flow history. It seems that Flow does not recognize it as a trigger. Also, I only know 2 users that sends an email who are not being recognized by flow as of the moment.

 

Ana

@chandrashekhar@v-yamao-msft: Just an update. I moved the get user after the create item then added "Update item" aciton but I'm getting an error: {
  "statusCode"404,
  "message""Resource not found"
}

 

Can you help me with this?

 

Ana

Helpful resources

Announcements
User Groups Public Preview

Join us for our User Group Public Preview!

Power Automate User Groups are coming! Make sure you’re among the first to know when user groups go live for public preview.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (42,339)