cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
IP
Regular Visitor

When an event is added, updated or deleted V3 - has suddenly started returning deleted regardless of actual action

Hi all,

 

New here but don't know where else to turn.  I've had a flow running for a week or so to "sync" my work outlook calendar to my personal google calendar.  Very simple flow.  Worked fine for several days but has now stopped actually doing anything because the trigger ALWAYS returns "deleted" regardless of what has actually happened in the calendar.  I've run numerous tests but I just can't understand why the action in the trigger output is always the same now when it worked properly for almost a week.

 

Any ideas?  Thanks,

 

IP

 

Edit-your-flow-Power-Automate.png

 

11 REPLIES 11
ErikvanB
Regular Visitor

Hi, I'm seeing this same issue. I have a similar flow and it ran well for months. Since June or July however, the trigger tells my flow that the Action Type is "deleted". Removed the trigger and put it back, but still the same thing. 

mkrizmancic
New Member

Hi, I also have this issue. Events are correctly created and updated, but then this broken trigger immediately deletes them. I only noticed this now, but I guess it could have started around June or July because I haven't had many events at that time.

Eventually I have re-created the flow and now the ActionType comes in correctly again. The old flows are deactivated. 

Oh! I'm having this exact problem. When you rebuilt your flows, did you do it from scratch? (I'm wondering if I can just copy it and re-add the condition or something, rather than redoing the whole thing.)

I did rebuild it from scratch indeed. I wanted to make some structural changes anyway, so it was OK. You can also try to save it as, or copy and past certain activities  (I believe it now supports copy-paste across flows). 

 

Good luck, hope you'll find a way to do this fast!

Update: I had the same problem appearing out-of-the-blue again. What I did this time, is Saved the flow As and then the new version seems to be working. Then just disable / delete the old flow. 

GaborSchilten
Frequent Visitor

I'm experiencing the same problem again after following the suggestion of creating a copy/new one.

Any new insights?

Hi @GaborSchilten , no new insights. This was working for me. Does it work if you rebuilt this again?

GaborSchilten
Frequent Visitor

It worked for a couple of weeks, then it failed again, same problem

 

Grover
Regular Visitor

FTR, here are two other reports of the same problem:

https://powerusers.microsoft.com/t5/Using-Connectors/Office-365-Outlook-quot-When-an-event-is-added-...

https://powerusers.microsoft.com/t5/Building-Flows/Issue-with-Outlook-trigger-When-event-is-added-up...

 

Both claim to be solved, but are just doing the same as here: when it stops working, make some random change / copy it and hope it starts working again till next time.

 

I guess I need to go and find out how I can automate copying and enabling/disabling flows, so I can automate this workaround.

Grover
Regular Visitor

Unfortunately the workaround of making a change to the flow / copying it, no longer works.

 

The flow stopped working again - all events are 'delete' - even in a new copy of the flow. Sigh.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (2,741)