cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Mark_Stewart
Advocate I
Advocate I

create csv file, does not put values in their own columns

I have a very simple cloud flow that should create a CSV file. It does, but the different values are not put in their own columns.
Here is the flow:

createCSV1.png

 

Here is a test:
createCSV2.png

 

What am I doing wrong?

 

And here is the the file:
createCSV3.png

1 ACCEPTED SOLUTION

Accepted Solutions
DamoBird365
Microsoft
Microsoft

Hi @Mark_Stewart 

 

I've since read that your delimiter might need to be setup here:

 

DamoBird365_1-1615883376308.png

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Cheers,
Damien


View solution in original post

7 REPLIES 7
DamoBird365
Microsoft
Microsoft

Hi @Mark_Stewart 

 

I have tried the same previously and both Excel Online and Desktop client open up my CSV in columns.  In the old days you had to use "Convert Text to Columns" and choose a comma as a delimiter, this should solve your problem short term.

 

DamoBird365_0-1615880857400.png

 

However, why doesn't it delimit automatically?  Have you tried creating a csv in notepad and uploading it to sharepoint to see if the same happens?  This would confirm if it was your flow or your configuration of Excel.

 

Once we know what is causing the problem, we can concentrate on exploring that area.

 

Thanks

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Cheers,
Damien

I was able to use the "Convert Text to Columns" and when I made a CSV file in notepad and uploaded it to SharePoint I got the same results as the flow. So you think it is Excel that is the problem and not the flow?

DamoBird365
Microsoft
Microsoft

Hi @Mark_Stewart 

 

It would certainly point to it being excel?!  Are you using the web client or desktop client?  

 

I see a similar recent (ish) discussion on the Excel forum https://techcommunity.microsoft.com/t5/excel/csv/m-p/2121230#M89096 but no answer of yet.  I don't know why my excel web client loads up CSVs first time vs yours though - open it up to community or try the excel forum?

 

DamoBird365_0-1615883127075.png

 

Damien

 

DamoBird365
Microsoft
Microsoft

Hi @Mark_Stewart 

 

I've since read that your delimiter might need to be setup here:

 

DamoBird365_1-1615883376308.png

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Cheers,
Damien


Ok, I live in Denmark and the regional format was set to that. I changed it to English USA and it immediately changed! So that was the problem. But now how can I get it to work with the Danish format?
createCSV4.png

Hi @Mark_Stewart 

 

You'll have to explore the regional format settings with your IT as they may set them globally.  I would however appreciate that you mark my answer as a solution as I believe I have demonstrated your problem and resolved it.  

 

Thanks,

 

Damien

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Users online (2,507)