cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jlynch92009
Frequent Visitor

create team with Power Automate - resource not found - sometimes

I have a flow that creates a Team.  I have a 1 minute delay then down the flow we need to get more info so I can create a link to the SP site created by the Team.  I use an http call with Graph and that works most of the time.  On occasion it fails with "Resource not Found"  I created a run after so that if it fails we wait 15 minutes and try again, now that one occasionally fails too.  Any idea why the issue is intermittent?  

 

further, before I invoke the graph call I get the Team using the new team id, use that ID to get the group, then in the graph call it fails, even though both of the previous calls work and yield correct results.

 

Here is the input for the graph call:

 

{
    "method""GET",
    "retryPolicy": {
        "type""Fixed",
        "interval""PT20S",
        "count"10
    },
    "authentication": {
        "tenant""xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx",
        "audience""https://graph.microsoft.com",
        "clientId""xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx3",
        "secret""*sanitized*",
        "type""ActiveDirectoryOAuth"
    }
}
 
and the outputs:
{
    "statusCode"404,
    "headers": {
        "Transfer-Encoding""chunked",
        "Vary""Accept-Encoding",
        "Strict-Transport-Security""max-age=31536000",
        "request-id""6deb3cf1-fb13-4255-b0ad-aa4d431a9233",
        "client-request-id""6deb3cf1-fb13-4255-b0ad-aa4d431a9233",
        "x-ms-ags-diagnostic""{\"ServerInfo\":{\"DataCenter\":\"West US\",\"Slice\":\"E\",\"Ring\":\"4\",\"ScaleUnit\":\"000\",\"RoleInstance\":\"BY1PEPF0000322A\"}}",
        "Date""Tue, 13 Jul 2021 17:44:03 GMT",
        "Content-Type""application/json",
        "Content-Length""227"
    },
    "body": {
        "error": {
            "code""ResourceNotFound",
            "message""Resource is not found.",
            "innerError": {
                "date""2021-07-13T17:44:03",
                "request-id""6deb3cf1-fb13-4255-b0ad-aa4d431a9233",
                "client-request-id""6deb3cf1-fb13-4255-b0ad-aa4d431a9233"
            }
        }
    }
}
 
again, this only happens once every 20 to 40 times.  let me know if you have ideas, as I said, i've already introduced 2 separate delays of 5 minutes and then on a run after another 15 minute delay so it doesn't seem to be a provisioning issue.
0 REPLIES 0

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Users online (2,609)