cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
givtajt
Frequent Visitor

error: Input parameter 'item/sddd' is required to be of type 'Number/double'

im trying to insert my MS form content to a list on sharepoint using a flow and im getting this error:

 

Input parameter 'item/sddd' is required to be of type 'Number/double'. The runtime value '"rdf"' to be converted doesn't have the expected format 'Number/double'.

 

I dont know what does it means "Item/sddd". the only numeric value i have on my form is the date which i created the column on my list of date/time type (even changed it to text and tested same error occurred)

 

grateful if any one could help to solve it

7 REPLIES 7
efialttes
Super User III
Super User III

Hi!

Can you share a screenshot from:

-your current flow design, so we can see 'Create item' input details ?

-your sharepoint list column config?

Thanx!



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



 
givtajt
Frequent Visitor

flow 1.JPGflow 2.JPGFlow 3.JPG

Hi!

It looks like your 'get response details' is inside an 'Apply to each, right?

If so, your flow is inplemented in the old fashioned way. Please have a look to this topic and see if you can redesign your flow without the 'apply to each'

https://powerusers.microsoft.com/t5/Building-Flows/Error-The-inputs-parameters-of-workflow-operation...

Hope this helps



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Hi @givtajt 

 

i've been looking into this issue recently. Some how the flow passing a null value to Sharepoint from blank fields in Forms.

 

The problem could be fix by edit the Sharepoint column from Number to Single line of text.

 

For now i'm not sure if this is by design or bug but we need to take more action on it.

SylLArry
New Member

Same problem

Assuming you can assign a default numeric value if empty response is received from Forms, coalesce() WDL function should do the trick

https://docs.microsoft.com/en-us/azure/logic-apps/workflow-definition-language-functions-reference#c...

Hope this helps



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (50,042)