cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Dan
Frequent Visitor

https Http Request URI issue

Hi,

I seem to be having an issue with HTTPS Http requests. I am getting "enter a valid uri" on the the request

 

the uri i'm using is: 

https://api.bamboohr.com/api/gateway.php/{subdomain}/v1/employees/directory

from:

https://www.bamboohr.com/api/documentation/

using basic auth.

i am replacing the {subdomain} with mine.

The URI works in postman

 

2 REPLIES 2
kkurni
Microsoft
Microsoft

It seems there is bug, if you copy paste directly to that text box.

 

I will create a bug for this.

 

But for workaround for now, try not to copy paste the whole thing into that text box.

 

Try this.

It's better to create a new flow and type in the first https://  and then you can copy paste it the rest.

 

 

Thanks

There is known sanitized /n issue. so when you copy paste directly, it may have that hidden invalid character.

 

So if you sanitized first, before you paste it into the box, it should work.

You can try to copy paste this into your browser url, and copy paste back to the box. 

 

(This is known bug issue which has been tracked on our site. (#547922)

 

Thanks

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (58,679)