cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

send an email notification says it works but doesn't actually send an email

I recently had to refactor some flows because not everyone that would use it had acess to exchange online, so I had to change the Outlook - Send email to the standard Send Email Notification v3 to guarantee that everyone gets the mail.

 

It should be a simple replacement task but when it came down to testing the flow it didn't actually send the emails even though it says it did.

I have 3 emails being sent with this connector and an approval in the middle. I only get an email from the Approval bit.

 

Has anyone experienced this?

15 REPLIES 15
rogrimbe
Helper I
Helper I

Hi MangoMan09, 

 

you'll need to share a bit more data, if you can. 

the flow screenshot and the last the run status that you said finished with success 

 

usually when the flow is green it finished fine and did what it should. I use v3 send email and don't have any issues so lets start with more data on your speific case that can help troubleshoot this

Anonymous
Not applicable

@rogrimbe sorry, I forgot to add those.

In the meantime I made a simpler version of the flow with only 1 variable and no approval, but in the end I had no luck.

It shows it ran successfuly but I don't receive the email.
Capture.PNGCapture1.PNG

Hi MangoMan09, 

thanks for the extra data, now I can see that you are using the SendGrid connector as the email notifications when you said change the outlook I failed to understand that so good thing you added that screenshot, 

I've just tested it and it is working fine for me. one var with my email and got the mail. 

below is the example mail received, did you double check the jank\spam? or maybe once got such emails and decided to unsubscribe? like the email says? (referring to aka.ms/flow-mail) 

 

test.JPGtest2.JPG

Anonymous
Not applicable

@rogrimbe thanks for the input. 

 

I tried sending to a couple other email addresses but I had no return emails again.

 

I checked all the email boxed and found nothing in them (spam, trash, etc). It's really strange that it worked once and never again. It's not even a complex flow to begin with...

I agree, its not.

and the fact that it is reaching the email and says it working is starnge. 

maybe stuck somewhere in the middle

Unfortuntly I can't be of any assistance here since I can't reproduce this.

maybe next step is to open an issue with Flow specific to this connector if you have no issue just sending an email to yourself with the other connectors like the outlook. 

Hi @Anonymous,

 

Have you checked the Junk Email? Maybe you've created a Flow before that when the Email with special subject arrives, delete it or move it to the Junk Email.

Have you tried to use another account to create this Flow? And how it runs?

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Anonymous
Not applicable

@rogrimbe Outlook was working fine but the custumer im working for doesn't have an exchange online account for all of the users so we had to swap connectors.

@v-litu-msft and @rogrimbe I tried on a whole enviornment all together and spammed flow. I got all of the emails so there's some hidden throttling on the enviornment I'm developing.

Hi @Anonymous,

 

Have you tried recreating the SendGrid connection?

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Anonymous
Not applicable

After some more testing I managed to get it working.

 

I went back to the outlook connector as that one was sending the messages just fine.

 

Then I changed the trigger from the PowerApps to running when a new row was added on the DB. This way they flow ran as intended and we don't have to worry about assigning more keys to the users later on.

Going to https://aka.ms/flow-mail and reinstating my email address did the trick for me. Thanks for the pointer!

Hor
Helper I
Helper I

Hi

 

I have encountered the same problem. I have one recurrence flow that send an email notification (V3) to users (Outlook) every day. The flow was working fine previously until yesterday (19/6/2020). I check the status is "Succeeded" but the email was not received by the users. I tried adding my personal email into the recipient and did receive the notification. It seems that there's something not working as it is between flow and outlook and it's really frustrating.

Anonymous
Not applicable

Hi all, 

 

Encountered the same issue, can any of the experts guide me please?

It showed my flow ran successfully, but I did not receive any emails to my inbox. 😞Capture.JPG

 

 

Please expedite help, thank you much!

 
 

 

Same here.

My flows with v3 connector have been successfully sending emails until few weeks ago and now they act really strange. I have had 5 flows sending emails scheduled for today and only 1 of them I received. And all the flows have succeeded status.

Just for testing purpose I have created another simple instant manual flow having only send email notification v3 connector and tested it and it is not sending emails and again status is succeeded.

Checked on my email server and no spam filter or anything else there. Did this reinstating of my address on https://aka.ms/flow-mail even though I never unsubscribed but that didn't help...

Does anyone knows what is going on and where to look for solution?

Hm. I have some progress here. It turns out that if I put some other email address in To: field and I was testing with one Gmail and one Hotmail account it works. And when I put my company email address it still does not receives emails from microsoft@powerapps.com. Is it possible that our domain or certain email addresses on our domain after some time and few received emails have somehow became blocked from receiving emails from this connector?

Once more, our spam filter is not blocking...

Hor
Helper I
Helper I

I switched to create a shared mailbox and use Officer365 Outlook connector to send the email instead.

Helpful resources

Announcements

Check out the Copilot Studio Cookbook today!

We are excited to announce our new Copilot Cookbook Gallery in the Copilot Studio Community. We can't wait for you to share your expertise and your experience!    Join us for an amazing opportunity where you'll be one of the first to contribute to the Copilot Cookbook—your ultimate guide to mastering Microsoft Copilot. Whether you're seeking inspiration or grappling with a challenge while crafting apps, you probably already know that Copilot Cookbook is your reliable assistant, offering a wealth of tips and tricks at your fingertips--and we want you to add your expertise. What can you "cook" up?   Click this link to get started: https://aka.ms/CS_Copilot_Cookbook_Gallery   Don't miss out on this exclusive opportunity to be one of the first in the Community to share your app creation journey with Copilot. We'll be announcing a Cookbook Challenge very soon and want to make sure you one of the first "cooks" in the kitchen.   Don't miss your moment--start submitting in the Copilot Cookbook Gallery today!     Thank you,  Engagement Team

Announcing Power Apps Copilot Cookbook Gallery

We are excited to share that the all-new Copilot Cookbook Gallery for Power Apps is now available in the Power Apps Community, full of tips and tricks on how to best use Microsoft Copilot as you develop and create in Power Apps. The new Copilot Cookbook is your go-to resource when you need inspiration--or when you're stuck--and aren't sure how to best partner with Copilot while creating apps.   Whether you're looking for the best prompts or just want to know about responsible AI use, visit Copilot Cookbook for regular updates you can rely on--while also serving up some of your greatest tips and tricks for the Community. Check Out the new Copilot Cookbook for Power Apps today: Copilot Cookbook - Power Platform Community.  We can't wait to see what you "cook" up!    

Welcome to the Power Automate Community

You are now a part of a fast-growing vibrant group of peers and industry experts who are here to network, share knowledge, and even have a little fun.   Now that you are a member, you can enjoy the following resources:   Welcome to the Community   News & Announcements: The is your place to get all the latest news around community events and announcements. This is where we share with the community what is going on and how to participate.  Be sure to subscribe to this board and not miss an announcement.   Get Help with Power Automate Forums: If you're looking for support with any part of Power Automate, our forums are the place to go. From General Power Automate forums to Using Connectors, Building Flows and Using Flows.  You will find thousands of technical professionals, and Super Users with years of experience who are ready and eager to answer your questions. You now have the ability to post, reply and give "kudos" on the Power Automate community forums. Make sure you conduct a quick search before creating a new post because your question may have already been asked and answered. Galleries: The galleries are full of content and can assist you with information on creating a flow in our Webinars and Video Gallery, and the ability to share the flows you have created in the Power Automate Cookbook.  Stay connected with the Community Connections & How-To Videos from the Microsoft Community Team. Check out the awesome content being shared there today.   Power Automate Community Blog: Over the years, more than 700 Power Automate Community Blog articles have been written and published by our thriving community. Our community members have learned some excellent tips and have keen insights on the future of process automation. In the Power Automate Community Blog, you can read the latest Power Automate-related posts from our community blog authors around the world. Let us know if you'd like to become an author and contribute your own writing — everything Power Automate-related is welcome.   Community Support: Check out and learn more about Using the Community for tips & tricks. Let us know in the Community Feedback  board if you have any questions or comments about your community experience. Again, we are so excited to welcome you to the Microsoft Power Automate community family. Whether you are brand new to the world of process automation or you are a seasoned Power Automate veteran - our goal is to shape the community to be your 'go to' for support, networking, education, inspiration and encouragement as we enjoy this adventure together.     Power Automate Community Team

Hear what's next for the Power Up Program

Hear from Principal Program Manager, Dimpi Gandhi, to discover the latest enhancements to the Microsoft #PowerUpProgram, including a new accelerated video-based curriculum crafted with the expertise of Microsoft MVPs, Rory Neary and Charlie Phipps-Bennett. If you’d like to hear what’s coming next, click the link below to sign up today! https://aka.ms/PowerUp  

Tuesday Tip | How to Report Spam in Our Community

It's time for another TUESDAY TIPS, your weekly connection with the most insightful tips and tricks that empower both newcomers and veterans in the Power Platform Community! Every Tuesday, we bring you a curated selection of the finest advice, distilled from the resources and tools in the Community. Whether you’re a seasoned member or just getting started, Tuesday Tips are the perfect compass guiding you across the dynamic landscape of the Power Platform Community.   As our community family expands each week, we revisit our essential tools, tips, and tricks to ensure you’re well-versed in the community’s pulse. Keep an eye on the News & Announcements for your weekly Tuesday Tips—you never know what you may learn!   Today's Tip: How to Report Spam in Our Community We strive to maintain a professional and helpful community, and part of that effort involves keeping our platform free of spam. If you encounter a post that you believe is spam, please follow these steps to report it: Locate the Post: Find the post in question within the community.Kebab Menu: Click on the "Kebab" menu | 3 Dots, on the top right of the post.Report Inappropriate Content: Select "Report Inappropriate Content" from the menu.Submit Report: Fill out any necessary details on the form and submit your report.   Our community team will review the report and take appropriate action to ensure our community remains a valuable resource for everyone.   Thank you for helping us keep the community clean and useful!

Users online (4,884)