cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper III
Helper III

send an email notification v3 isn't working

Hey all,

 

I've created a form in Powerapps where it's possible to add an attachment.

After the forum get's submitted I want to notify someone in the organization by email with the information about the form (incl. the attachment).

I've created the flow below when I submit the form the flow runs successful, but it doesn't send a mail.. Before it did send the email, but overnight somehow it doesn't send it anymore.

Email will not send.JPG

Does anyone know how to fix this? I have the idea this happens me often

 

Thanks!

Ramon

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Super User
Super User

Re: send an email notification v3 isn't working

Hi @Ramonnooijen 

 

Thanks for the screenshot. Expand the Get Attachments step before the foreach and see what that returns. That might be returning null hence For each loop is not iterating the inside actions.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

View solution in original post

Dual Super User
Dual Super User

Re: send an email notification v3 isn't working

Hi!

My suggestion is to add a Condition action block before he apply to each, evaluate if get item 'has attachments' is true, on the false branch add a Terminate action block

As @abm suggests, it looks like no attachment is stored, so no there is not Apply to each iteration

Hope this helps 



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



View solution in original post

8 REPLIES 8
Highlighted
Super User
Super User

Re: send an email notification v3 isn't working

Hi @Ramonnooijen 

 

Check your run history? Which email connector are you using? 

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Highlighted
Helper III
Helper III

Re: send an email notification v3 isn't working

Hi @abm,

 

When I check my run history I can open the apply to each field and see the details in this field.

 History run 27032020.JPG

 

When I check the last run I can't view the details Apply to each is vinked correctly but the send email isn't, could this be the issue?

 

New run.JPG

 

The connectors are active so I don't know if that can be an issue, might need a reset?

 

Thanks!

Ramon

Highlighted
Super User
Super User

Re: send an email notification v3 isn't working

Hi @Ramonnooijen 

 

Thanks for the screenshot. Expand the Get Attachments step before the foreach and see what that returns. That might be returning null hence For each loop is not iterating the inside actions.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

View solution in original post

Highlighted
Helper III
Helper III

Re: send an email notification v3 isn't working

Hi @abm ,

 

I've tried to get attachment content before the apply to each, but it automatically get set back to apply to each.

If I unlock the mail out of the apply to each I can't find the attachment content in the email.

 

attachment content can't be selected.JPGapply to each created automaticaly.JPG

Strange that it worked before and now not anymore.

 

Thanks.

Ramon

 

Dual Super User
Dual Super User

Re: send an email notification v3 isn't working

Hi!

My suggestion is to add a Condition action block before he apply to each, evaluate if get item 'has attachments' is true, on the false branch add a Terminate action block

As @abm suggests, it looks like no attachment is stored, so no there is not Apply to each iteration

Hope this helps 



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



View solution in original post

Highlighted
Helper III
Helper III

Re: send an email notification v3 isn't working

Hi @efialttes and @abm ,

 

So it looks like if there is no attachment it will not apply to each what will mean there is no email to be send? is that correct?

I'll add an condition and check if that will work.

 

Thanks!

Highlighted
New Member

Re: send an email notification v3 isn't working

did it work... inquiring minds want to know.

Thanks,

~Cyn

Highlighted
Helper III
Helper III

Re: send an email notification v3 isn't working

Hi @Cyn-OriginalCyn 

 

Yes it worked, somehow the mail didn't send if there wasn't an attachment.

So it did send if there was an attachment, but it didn't if there wasn't

I had to create a condition as below with a "true" if there is an attachment and "false" if there is no attachment.

 

If it's true I've used the apply to each formula and in the false only the email without an attachment.

 

This worked for me, the only issue that I run into is that the condition didn't want to work, so I have created an invisible attachment counter which counts my attachments, so if it's 0 there are no attachments, if it's 1 there is 1 attachment and so on

 

 

Condition attachment.JPG

 

I hope it's clear how I got it running for my case 🙂

 

Kind Regards,

 

Ramon

Helpful resources

Announcements
firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (12,879)