cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JACK_LAI_1117
Resolver I
Resolver I

send an http resquest to sharepoint get error 401

HI:

   userA and userB are all this sharepoint site member , after  userA created app+automate then share app to userB .....

   In automate had used "send request to sharepoint " , after userA finished all column in apps then click "submit" , then automate finished success ,  but userB .....after he click "submit " the automate will get error in "send request to sharepoint"

 

  this pic is what content in 

JACK_LAI_1117_0-1623148039097.png

 

the error message 

JACK_LAI_1117_1-1623148162128.png

 

 

so which wrong with my automate ?????? please help me !!!!!!

 

1 ACCEPTED SOLUTION

Accepted Solutions

@JACK_LAI_1117  with PowerApps trigger the flow runs under user who triggered the flow from PowerApps, so in your case the flow runs under User B account when user B users the PowerApp.

 

Now you are getting error in breaking item level permissions, as you mentioned that User B has member access on the site, the users who have member access cannot break permissions on item, that is why you are getting 401 unauthorized, you need to provide more permissions to user B to allow them to break permissions on item.

Regards,
Anna Jhaveri

If I have answered your question, please mark the post as Solved to help other users to identify the correct answer
If you like my response, please give it a Thumbs Up.

View solution in original post

4 REPLIES 4
annajhaveri
Super User
Super User

@JACK_LAI_1117  what trigger is used in the flow?

Regards,
Anna Jhaveri

If I have answered your question, please mark the post as Solved to help other users to identify the correct answer
If you like my response, please give it a Thumbs Up.

@annajhaveri 

 

the trigger is "powerapps "

 

I put this function after "create item".

@JACK_LAI_1117  with PowerApps trigger the flow runs under user who triggered the flow from PowerApps, so in your case the flow runs under User B account when user B users the PowerApp.

 

Now you are getting error in breaking item level permissions, as you mentioned that User B has member access on the site, the users who have member access cannot break permissions on item, that is why you are getting 401 unauthorized, you need to provide more permissions to user B to allow them to break permissions on item.

Regards,
Anna Jhaveri

If I have answered your question, please mark the post as Solved to help other users to identify the correct answer
If you like my response, please give it a Thumbs Up.

View solution in original post

@annajhaveri 

 

Got it , it is very important infromation to me , and let me know what the permission operation model in powerapps+powerautomate .

 

 

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (2,593)