cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RyuTaka
New Member

unable to parse response JObject error with WebhookKeywordTrigger

Hello community!

I've set up a program that uses WebhookKeywordTrigger to transcribe a post to Excel when a specific keyword is tweeted on a Teams channel, but I'm getting this error and the program won't go any further.

Does anyone know what could be causing this?

 

 

Unable to parse response JObject:{
  "responses": [
    {
      "id": "0",
      "status": 404,
      "headers": {
        "Cache-Control": "no-cache",
        "Content-Type": "application/json"
      },
      "body": {
        "error": {
          "code": "ResourceNotFound",
          "message": "The object was not found.",
          "innerError": {
            "date": "2022-08-02T07:03:04",
            "request-id": "a*******-9***-4***-8***-3***********",
            "client-request-id": "a*******-9***-4***-8***-3***********"
          }
        }
      }
    }
  ]
}

 

 

here's the code I'm putting together here.

 

{
    "inputs": {
        "host": {
            "connectionName": "shared_teams",
            "operationId": "WebhookKeywordTrigger",
            "apiId": "/providers/Microsoft.PowerApps/apis/shared_teams"
        },
        "parameters": {
            "threadType": "channel",
            "$search": "PostVerificationOfBenefits",
            "requestBody/groupId": "4*******-e***-4***-b***-1***********",
            "requestBody/channels": [
                "1************"
            ]
        },
        "authentication": "@parameters('$authentication')"
    },
    "metadata": {
        "operationMetadataId": "6*******-0***-4***-8***-3***********"
    }
}

 

Can someone please help?

1 ACCEPTED SOLUTION

Accepted Solutions

Thank you for your response.
Unfortunatelly, on/off switch you introduced did not work for me, but I copied the exact same flow and turned it on and it solved the problem.

I don't think it solved the essential problem, but I'm glad I escaped the nightmare of manually copying and pasting for the time being!
Thank you for your referral.

View solution in original post

2 REPLIES 2
EridD94
New Member

Thank you for your response.
Unfortunatelly, on/off switch you introduced did not work for me, but I copied the exact same flow and turned it on and it solved the problem.

I don't think it solved the essential problem, but I'm glad I escaped the nightmare of manually copying and pasting for the time being!
Thank you for your referral.

Helpful resources

Announcements
October Events

Mark Your Calendars

So many events happening this month - don't miss out!

 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Users online (1,892)