cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
k1ng
Helper I
Helper I

Deleting topics that was created in the Bot Framework

I have make couple test topics on the bot frameworks but now I want to delete the topics and I can't seem to delete them? They just pop up again after I delete them?
k1ng_0-1617198654873.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
Robulane
Microsoft
Microsoft

@k1ng , Thank you for reporting this issue. We were able to reproduce it and are working on the fix.

This is a workaround you can use to delete these components:
1. Open PowerApps portal

2. Go to Data->Tables

3. Change "Default" to "All" on Top Right 
4. Select "Chatbot subcomponent" table

Robulane_0-1617217708556.png


5. Open this table
6. Open "Data" tab
7. Find the component you want to delete
8. Select it and click on "Delete record"

View solution in original post

5 REPLIES 5
renatoromao
Super User
Super User

Hi @k1ng ,

 

Did you try to delete inside your custom topic?

What did I mean?

Go to the topic that you tested >> remove the action connected to the Bot Framework Composer >> Now, go to your Bot Framework Composer topic inside PVA topics tab and remove there.


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.650 students) : English | Português

in the pva?  Don't have a delete option to remove it in the bot framework trigger?

k1ng_0-1617203784746.png

 

 

k1ng
Helper I
Helper I

in the composer, remove the trigger and publish it back into the pva?

k1ng_1-1617203907126.png

 

Update:  tried that, same issue.  When I published back into the PVA, still won't delete.. Just pops back up again after I "delete" it.. 

renatoromao
Super User
Super User

@k1ng ,

 

We are investigating this issue and we will let you know as soon as possible.


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.650 students) : English | Português
Robulane
Microsoft
Microsoft

@k1ng , Thank you for reporting this issue. We were able to reproduce it and are working on the fix.

This is a workaround you can use to delete these components:
1. Open PowerApps portal

2. Go to Data->Tables

3. Change "Default" to "All" on Top Right 
4. Select "Chatbot subcomponent" table

Robulane_0-1617217708556.png


5. Open this table
6. Open "Data" tab
7. Find the component you want to delete
8. Select it and click on "Delete record"

View solution in original post

Helpful resources

Announcements
PVA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Center-of-Excellence-Starter-Kit-cropped 768x460.png

The Total Economic Impact™ of Power Virtual Agents

Read this 2021 commissioned study, conducted by Forrester Consulting.

Top Solution Authors
Users online (1,481)