cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kensley
Resolver I
Resolver I

How to create more flows for an existing bot?

Hello,

I am currently working on a bot within Power Virtual Agents.  At the moment I have 16 flows connecting to the same SharePoint list.  In my attempt creating a 17th flow connecting to the same list, I received the following message:

 

kensley_0-1615223657800.png

 

How can I bypass this limitation and continue adding more flows for my custom bot?

 

I did some research and found the following article by Microsoft on the limitation :

https://docs.microsoft.com/en-us/powerapps/maker/common-data-service/create-connection-reference

 

But I need a visual description of creating a new connection reference for my bot...what does that visually mean in my case?

1 ACCEPTED SOLUTION

Accepted Solutions
Jcook
Super User
Super User

Hi @kensley 

 

adding to @renatoromao point.

Connections can only be used for 16 flows at one time. All you need to do is create a new connection for SharePoint.


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





View solution in original post

9 REPLIES 9
renatoromao
Super User
Super User

Hi @kensley ,

 

Go to your SharePoint action inside your workflow >> "..." >> Add a new connection. Also, change all connections inside this flow to use this new connection.

This change will help you to save it.


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.650 students) : English | Português
Jcook
Super User
Super User

Hi @kensley 

 

adding to @renatoromao point.

Connections can only be used for 16 flows at one time. All you need to do is create a new connection for SharePoint.


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





View solution in original post

Thanks.  Last question, what special permissions does one need to create a new connection reference?  When I attempt to do so by signing in, it returns a white browser screen that never stops loading.

@kensley  inside flow, click the 3 dots on the action and click create new connection. Anyone that has access to Power Automate can create connections


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





renatoromao
Super User
Super User

Hi @kensley ,

 

I saw the same issue today. I solved it by closing all browsers and opening it again.

In theory, you can use the same permissions that you have in another connection that you are using now.


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.650 students) : English | Português
kensley
Resolver I
Resolver I

Sorry for asking another question.  You guys are great!  But when I need to connect to my existing Connector, is that the name of my flow?  or should that be Microsoft Teams? sense I'm using Power Virtual Agent inside of it?

 

Many thanks

kensley
Resolver I
Resolver I

I wish I could move on with this as you guys are making it super clear on things.  But I can't.  I do have access to Power Automate, but when I click the link to add a new connection within Power Virtual Agents, a browser window opens and puts me into a loop of the following page. I have to believe I am not the only person who has ever experienced this.  I even tried to closing all my browsers, but that didn't matter.  This page always pops up this way...

 

kensley_0-1615232497104.png

 

kensley
Resolver I
Resolver I

I'm on to to something.  The issue only occurs if you attempt to create a new connection from within Power Virtual Agents within Microsoft Teams. If I click for a new connection in Power Virtual Agent' standalone app, it allows me to setup a new connection. 

 

Has this already been reported?

Seeing the same issue (infinite loading), and I cannot find/login to Power Virtual Agents desktop app. Is there any other solution to this?

Helpful resources

Announcements
Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Center-of-Excellence-Starter-Kit-cropped 768x460.png

The Total Economic Impact™ of Power Virtual Agents

Read this 2021 commissioned study, conducted by Forrester Consulting.

Users online (2,909)