cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DS2
Advocate III
Advocate III

I don't see "Open in Bot Framework" when in any of my 4 bots on the topic page in PVA

I've been following through this document: https://docs.microsoft.com/en-us/power-virtual-agents/advanced-bot-framework-composer?WT.mc_id=AZ-MV... and I wanted to test accessing Bot Framework Composer from within Power Virtual Agents.

  1. I have 4 bots, and have tested with them all - I have composer (1.3) installed on my machine. Closed or open made no diference.
  2. I go to the topics tab for any of the bots
  3. in the screenshot in the documentation, it shows "Open in Bot Framework (preview) across from "suggest topics"
  4. I do not have Open in Bot Framework (Preview)

Is there something I need to do for this to show up for me?No Bot Framework.jpg

2 ACCEPTED SOLUTIONS

Accepted Solutions
renatoromao
Super User
Super User

@DS2 ,

 

@MarKol  can confirm better, but I know this issue is related to a free license, right? 

I heard something like that but I don't remember.

 

Also, we have a pending topic here: Allow customer to send multiple lines message - Power Platform Community (microsoft.com)


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.300 students | PROMOTIONS) : English | Português

View solution in original post

MarKol
PVA
PVA

The PVA team made some updates to fix this issue.

 

Can you please check if you can see the "Open in Bot Framework" button in your PVA now?

 

You should see it on the portal if you have full Prod or full Trial license. Thanks for flagging the issue and letting us know ASAP!

View solution in original post

15 REPLIES 15
renatoromao
Super User
Super User

Hi @DS2 ,

 

Unfortunately, this feature is unavailable now.

Microsoft is working on it to turn it on again, but some environments are disabled this feature too.


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.300 students | PROMOTIONS) : English | Português
DS2
Advocate III
Advocate III

@renatoromao - thank you so much for the information. Is there a link\URL you could point me at for more information from Microsoft on this? 

MarKol
PVA
PVA

Hi @DS2 ,

 

 what Region/Country is your bot in? Are you using Teams to create your bots, or a web portal?

 

Thanks!

renatoromao
Super User
Super User

@DS2 ,

 

@MarKol  can confirm better, but I know this issue is related to a free license, right? 

I heard something like that but I don't remember.

 

Also, we have a pending topic here: Allow customer to send multiple lines message - Power Platform Community (microsoft.com)


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.300 students | PROMOTIONS) : English | Português

View solution in original post

DS2
Advocate III
Advocate III

Ah yes, thanks. Our prod tenant shows the Bot Framework hook-in, but our test tenant (with a test license) doesn't. Appreciate it!

MarKol
PVA
PVA

@DS2 , could you please confirm? The entitlement issue that was causing this button not showing up for Teams users even if they had a full PVA license was supposed to be fixed. But we are getting signals that there might be an addiotnal issue regarding solution/region determination at play.

Would be great to confirm.

Jcook
Super User III
Super User III

@MarKol,

 

Is a Full/Paid license needed for this?

 

Does this work for trial?


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





Hey @Jcook

Yep, you need premium license to use Bot Composer
See call out in docs: https://docs.microsoft.com/en-us/power-virtual-agents/advanced-bot-framework-composer

Michael

Jcook
Super User III
Super User III

@mivakoc 
Thank you!

 

The call out says, trial or full license.

I am using a trial, and in the portal the option is missing for me


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

March Update

Welcome to the User Group Private Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (17,799)