cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Not able to create flow using Power Automate.

Hi,

 

I am trying to create a flow using Power Automate through Power Virtual Agent. I am trying to connect to Servicenow. Everytime i try to do this i see the below error. I am not able to connect. 

 

Request to XRM API failed with error: 'Message: Flow client error returned with status code "Forbidden" and details "{"error":{"code":"MissingAdequateQuotaPolicy","message":"The user '8ad1e23f-1777-4150-86cd-424e3458066c' does not have a service plan adequate for the non-Standard connection. https://go.microsoft.com/fwlink/?linkid=2123710"}}". Code: 0x80060467 InnerError: Type: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=9.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]] Message: Flow client error returned with status code "Forbidden" and details "{"error":{"code":"MissingAdequateQuotaPolicy","message":"The user '8ad1e23f-1777-4150-86cd-424e3458066c' does not have a service plan adequate for the non-Standard connection.

 

 

Can anyone please help me out here?

 
1 ACCEPTED SOLUTION

Accepted Solutions
renatoromao
Super User
Super User

Hi @Anonymous ,

 

Please take a look at Office 365 Admin Center, check the user license information from there.

Make sure the Microsoft Flow Plan 2 is assigned to the user.

Besides, please also take a check for the connections used for the Action added in your flow. Such as the ServiceNow connection, and the action followed.

 

---
If you like this reply, please give kudos. And if this solves your problem, please click on "Accept as Solution" button.

Thanks!
Renato Romão
https://www.linkedin.com/in/renatoromao/


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.760 students) : English | Português

View solution in original post

4 REPLIES 4
renatoromao
Super User
Super User

Hi @Anonymous ,

 

Please take a look at Office 365 Admin Center, check the user license information from there.

Make sure the Microsoft Flow Plan 2 is assigned to the user.

Besides, please also take a check for the connections used for the Action added in your flow. Such as the ServiceNow connection, and the action followed.

 

---
If you like this reply, please give kudos. And if this solves your problem, please click on "Accept as Solution" button.

Thanks!
Renato Romão
https://www.linkedin.com/in/renatoromao/


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.760 students) : English | Português
RezaDorrani
Dual Super User
Dual Super User

Hi @Anonymous 

 

The account under which the flow is running would require the per user plan or the per flow plan needs to be assigned to the flow as you are using a premium connector.

 

https://us.flow.microsoft.com/en-us/pricing/

You can also test this out by acquiring the trail for the per user plan (40$) provided in the link above.

 

--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

Thanks,
Reza Dorrani, MVP
YouTube
Twitter

Hi @Anonymous,

 

did you create your flow by using "Create a new flow" option from Action node in PVA? 

 

If not, can you please re-create your flow by using "Create a new flow" option from Action node and see if you still see the problem? 


As part for PVA License, you also get Power Automate entitlements and ability to use Premium Connectors like ServiceNow, but they are only valid to flows created via "Create a new flow" option in PVA and PVA Connector needs to be used.

 

So if you have created you flow from scratch on Power Automate portal, even if you are using PVA Connector, hit might not count towards Premium connector entailment you get via PVA license.

In addition to @MarKol's questions - do you get this error when you trigger the flow from within a conversation with the bot or directly from the Power Automate portal?

Thanks, 
Michael

Helpful resources

Announcements
Power Virtual Agents News & Announcements

Power Virtual Agents News & Announcements

Keep up to date with current events and community announcements in the Power Virtual Agents community.

Power Virtual Agents Community Blog

Power Virtual Agents Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (6,395)