cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dsab81
Microsoft
Microsoft

PVA Authentication : Dont see an Option to add 'Authentication' on calling an Action in Topics

Hi ,

I have configured the Manual Auth as suggested in Configure user authentication - Power Virtual Agents | Microsoft Docs

But when i go to topics and call action , i dont see the Authenticate option.

 

Not sure whats wrong with the configuration. I have tried both OAuth V2 & AD V2 setup of Authentication and both doesnt allow me to get to see the Authentication on calling the Action.

 

Please suggested.

 

dsab81_0-1617409851849.png

 

 

My Authentication Setup is below 

dsab81_0-1617412302436.pngdsab81_1-1617412343336.png

 

and my AAD Registration is like below : 

 

Redirect URL's

dsab81_3-1617412485365.png

 

API Permissions :

dsab81_4-1617412523788.png

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Jcook
Super User III
Super User III

Hello @dsab81 

 

As a test, could you create a brand new topic and add the Call an action block to see if Auth is available.

 

Let me know,

Thanks

 


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





View solution in original post

@dsab81  this is a limitation in Power Virtual Agents authoring experience today. Authentication nodes can only be added to the last node on a conversation. After that's added, you can add other nodes underneath. 

View solution in original post

3 REPLIES 3
Jcook
Super User III
Super User III

Hello @dsab81 

 

As a test, could you create a brand new topic and add the Call an action block to see if Auth is available.

 

Let me know,

Thanks

 


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





View solution in original post

dsab81
Microsoft
Microsoft

Yes. i could see the auth option available when i create new topic.

Also i was able to see the auth option in the existing topic as well, but it allows to add only towards the end of topic nodes , but could not add it in the middle of topics whether it is a new or a old topic.

 

Why is that? 

@dsab81  this is a limitation in Power Virtual Agents authoring experience today. Authentication nodes can only be added to the last node on a conversation. After that's added, you can add other nodes underneath. 

View solution in original post

Helpful resources

Announcements
V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

PVA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Users online (1,985)