cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mlaurich
Advocate II
Advocate II

PVA in a Day training has Bug in Lab 5

Downloaded and installed the PVA in A Day solution

 

All was working smoothly until Lab - 05-Integrate with prebuilt Power Automate flows.pdf

 

Task 3: Add Return Item action to the conversation

When I select the 'Call an action', the "Return Item" flow shows up in the choices however I cannot select it. Just highlights it...I can select the other "Get Order Info" flow.....In addition I am able to select the View Flow Details and it opens Power Automate...I am able to edit/save the flow but nothing appears to make it selectable.

 

In previous lab step (Task 2: Call Get Order Info by Email action) you call the "Get Order Info" flow and that worked fine.

 

Any thoughts on why this would not work? I even re-imported the solution to see if this was an issue but appears it is a bug in the training?

 

New Bitmap Image.jpg

1 ACCEPTED SOLUTION

Accepted Solutions
MarKol
PVA
PVA

Hi mlaurich,

 

 

for the flows that that not showing in PVA, please go to Power Automate portal and check if these flows have any inputs/outputs with names that have spaces, numbers or any special characters in them.

 

If if find any, please try renaming such variables to have only characters and "_"  in the flow, save the flow and go to PVA to see if they now show up.

 

Unfortunately, there is a regression (already being fixed) in PVA that makes the bot consider flows with variable names containing spaces, numbers, special characters as invalid. Renaming these variable should fix it.

 

PS: this bug is already in process of being addressed.

View solution in original post

4 REPLIES 4
MarKol
PVA
PVA

Hi mlaurich,

 

 

for the flows that that not showing in PVA, please go to Power Automate portal and check if these flows have any inputs/outputs with names that have spaces, numbers or any special characters in them.

 

If if find any, please try renaming such variables to have only characters and "_"  in the flow, save the flow and go to PVA to see if they now show up.

 

Unfortunately, there is a regression (already being fixed) in PVA that makes the bot consider flows with variable names containing spaces, numbers, special characters as invalid. Renaming these variable should fix it.

 

PS: this bug is already in process of being addressed.

Yes @MarKol ,

 

Inside the workflow the response has space.

 

pva-in-a-day.png


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.760 students) : English | Português

this should be renamed from "Return Code" to "Return_Code".  This should make it show on the list of available flows.

 

the bug fix will be in Prod soon.

Perfect and great to know but sounds like will be a non issue moving forward. As soon as I removed spaces, all worked perfect. Thanks so much for the fast reply

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Power Virtual Agents Ideas

Changes to Ideas Coming

We are excited to announce a new way to share your ideas for Power Virtual Agents!

Users online (2,650)