cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

SSO in PVA

Hi all,

Has any one tried configuring SSO in PVA.

I am trying do the same but facing some issues.
After completing the configuration as per - https://docs.microsoft.com/en-us/power-virtual-agents/configure-sso.

 

i am getting error as- AADSTS50011: The reply URL specified in the request does not match the reply URLs configured for the application:<GUID>.

 can any on help me in the same.

2 REPLIES 2

This is usually a sign that you canvas application's reply URL (== redirect URI) is not configured to be the URL where your chat canvas is hosted. Here's the instruction,

 

>> Under Redirect URIs add the full URL to the page where your chat canvas is hosted. Under the Implicit grant section, select the Id Tokens and Access Tokens checkboxes.

 

Hope that works.

 

-Pawan

@Amol_Kavnekar / @RezaDorrani - There's a bug in our documentation where the screenshot to illustrate entering the redirect URL is showing 'https://token.botframework.com..' endpoint when it should really be 'https://<your web page's URL>'. That seems to be the cause of confusion here. We will be fixing the documentation soon.

 

Thank you!

Helpful resources

Announcements
PVA Commnity Blog

NEW Power Virtual Agents Community Blog

View articles posted by fellow community members on the Power Virtual Agents Community Blog!

Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Users online (7,498)