cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Dual Super User III
Dual Super User III

Share a bot with your Team - need to submit for admin approval first? - Teams Preview

Hi!

So thanx to the Teams PReview recently announce I just followed the steps to publish a bot 

https://docs.microsoft.com/en-us/power-virtual-agents/teams/publication-add-bot-to-microsoft-teams-t...

 

Once verified I can invoke my own flow, next step is to share it with my teammates .

The point is, they can see the bot in Built for your-organization-name > Built by your colleagues section, but when they doubleclick on it, an error message is displayed:

PVA_TeamsBOTS.png

The text explain 'Either the app does not exist or your org does not allow you to use it'. Taking into my teammates can already see the bot icon in Built by your colleagues section, I guess the problem is org permissions related.

 

My question is, do I need to submit the app for admin approval first, and get their explicit permission to share it with my teammates?

Thanx!



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



24 REPLIES 24
Highlighted
Super User
Super User

Hi @efialttes ,

 

Thanks for using the Teams preview! 

 

No, if you colleague wants to share the chatbot with you, he needs to:

  1. Go to the Chatbot tab.

  2. Open the bot you want to share.

  3. On the side navigation pane, select Publish.

  4. Select Share the bot.

  5. Select Add to Teams. This will automatically add the bot to the Built by your colleagues section, and will show a green label Added to Teams.

Automatically adds your bot to the Built by your colleagues section in Teams.

If your app doesn't appear in the Built by your colleagues section, your Teams app might be caching information. Try signing out and back in again (if you're using the desktop app) or refreshing your browser (if you're using the web app of Teams).


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+1.000 students | 25% OFF) : https://www.udemy.com/pva-beginners
Highlighted

Hi!

Yeap. I followed the steps you mention. So the app icon is displayed, but when doubleclicking on it the error explained in my first post is displayed (screenshot shows the bot icon, also the popup error). That's why I am asking if we needed admin consent first

Thanx!

 



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Highlighted

I also have this issue. The error also happens when you click Open Chat Bot but works correctly in testing.

 

stephenyoung89_0-1602678043956.png

 

Highlighted

Thanx for sharing!

I'm still stuck also, and conventional ticket support does not cover Previews, they reference this community

I wish Microsoft support team can provide us a good suggestion

 

 



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Highlighted

Hello @renatoromao ,

I have the same problem. But my Chatbot doesn't even appear in my: "Built for "TenantName". I signed out and back in again, same result. When I click open Chatbot the error message appears.

 

error0.pngerror1.pngerror2.png

Highlighted

Hi @calerof ,

 

Did you try to publish your chatbot again?

I'm trying to simulate your scenario and calling the Microsoft team.

 

If I saw any updates, I will post here 🙂


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+1.000 students | 25% OFF) : https://www.udemy.com/pva-beginners
Highlighted

Of course I published it.

errorPub.png

Highlighted

Thank you everyone for the great discussion, the ability to open the bot and share it with your team requires your organization to allow 'Shared Power Virtual Agents' in the Teams admin center.  If that is turned off, then you will not be able to open the bot in Teams and the bot will not show up in 'built by your colleague' section.  You would need to work with your admin to have it enabled.

 

For more detail you can find it in our documentation for more detail:

https://docs.microsoft.com/en-us/power-virtual-agents/teams/publication-add-bot-to-microsoft-teams-t...

https://docs.microsoft.com/en-us/microsoftteams/manage-power-platform-apps

 

Highlighted

@micchow 

It's allowed, not working.

error.png

Helpful resources

Announcements
PVA Commnity Blog

NEW Power Virtual Agents Community Blog

View articles posted by fellow community members on the Power Virtual Agents Community Blog!

Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Users online (3,467)