cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Sorry, the bot can't talk for a while. It's something the bot's owner needs to address. Error code: 2001.

I'm working on a PVA bot that brings in a QnA knowledge base via the MS Flow connector and feeds into Teams. 

 

I've encountered this issue a few times today after publishing updates to the bot and testing it within Teams and also the testing chat window within the PVA environment. I can't see any issues anywhere, I have a feeling this is just that it's slow to push the updates to the channels that the bot is working in but can anybody confirm this?

9 REPLIES 9
Super User
Super User

Hi @JosephBurkey ,

 

Did you have the same issue yet?


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.300 students | PROMOTIONS) : English | Português

Hi @JosephBurkey ,

 

I'm getting the same issue now.

I already reported it to the Microsoft team, if I get any updates, I'll send it here. 😉


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.300 students | PROMOTIONS) : English | Português

Hi @JosephBurkey ,

 

Updates 15/10/2020: Microsoft is working on it to fix this issue and they will notify me when finishes it. 


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.300 students | PROMOTIONS) : English | Português

Hi Renato, 

 

Ah great. Have they given any insight into what is causing it?

No @JosephBurkey , but I think that it's related to new features inside the PVA.


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.300 students | PROMOTIONS) : English | Português

I'm also facing the same issue. Any updates on this from Microsoft support?

Hi @Raj_explore ,

 

Unfortunately, not yet. 😞


Did I answer your question? Mark my post as a solution!
Thanks!

Renato Romão,

Connect with me here 😉

Power Virtual Agents course (+2.300 students | PROMOTIONS) : English | Português

Hello @renatoromao 

 

In my case I was able to figure out and it was the issue with the date format. The date format in Dynamics for DOB field was different than the date format in the Power Automate referred by the PVA for contact's authentication purposes. It looks like the Dynamics didn't like the DD/MM/YYYY format. As soon as I matched the date format (to MM/DD/YYY) in Power Automate, the error disappeared.

 

I guess it could be same with the other cases as well. Hope this helps!

 

Thanks!

Frequent Visitor

Hi @renatoromao   Any solution for this? I am getting Error 2001 too.

Helpful resources

Announcements
New Super Users

Meet the Power Virtual Agents Community Super Users!

Congratulations to our Season 1 2021 Super User Crew!

PVA Commnity Blog

NEW Power Virtual Agents Community Blog

View articles posted by fellow community members on the Power Virtual Agents Community Blog!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

Users online (104,203)