cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
_sourcecod3_
Helper IV
Helper IV

Unable to save PVA flow - Request to XRM API Failed

Hello,

I'm trying to save a PVA flow for my test chatbot, but I keep running into the below error message: 

 

PVA Error Msg.PNG

 

I'm not even trying to pull data from Dataverse, which makes it confusing.. 

 

Has anyone ran into this issue before? Any way to fix this? 

 

Thanks

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @Expiscornovus the issue has been resolved. Thanks!

View solution in original post

10 REPLIES 10
Expiscornovus
Super User
Super User

Hi @_sourcecod3_,

 

The error code suggests a web service error called MissingWebToLeadRedirect, The redirectto is missing for web2lead redirect. Doesn't ring a bell for me directly:

https://docs.microsoft.com/en-us/powerapps/developer/data-platform/org-service/web-service-error-cod...

 

My approach would be:

- Create a new flow from scratch. Save it every time after you add an action. That way at least you know which action is causing this and you have something to fall back on. Also makes troubleshooting a bit easier.

- Or remove the actions one by one from the existing one until you are able to save it.

Hi @Expiscornovus 

I´m having the same problem. And it happen even with just the PVA in and OUT on the flow.
In other words: I create the flow by the simple model for Power Virtual Agents and just try to save it before add any actions and the app give me that error. So, I think this is an error maybe unknow yet.

 

SivaPrasad2007
New Member

Hi Team
Even I am facing this issue, @GustavoDuarte did you find any resolution?

GustavoDuarte
Frequent Visitor

Not yet. I´m think this is an general error. Not sure!

Expiscornovus
Super User
Super User

Hi @GustavoDuarte,

 

Yes I agree. Looks like a pretty generic web service error. 

 

I have also seen it in this thread. Might be worth following as well:

https://powerusers.microsoft.com/t5/Calling-Actions-from-PVA/PVA-on-Teams-Error-Message-The-ExecuteT...

 

Expiscornovus
Super User
Super User

Hi @_sourcecod3_,

 

Can you still reproduce the issue? I saw in the other thread that the issue should be mitigated now.

SivaPrasad2007
New Member

Hi @Expiscornovus ,
From yesterday night, I don't see any issue. I am able to save the flow created through PVA in teams.

@SivaPrasad2007 I'll give it a shot and let you guys know. 

 

Thanks

shkaranam
Microsoft
Microsoft

Hi All,

I am still facing this issue. Till yesterday all my PVA flows were good. Then, all of a sudden I cannot save any of the flows created from the PVA. Is there something that I should do in order to resolve this?

 

shkaranam_0-1628710431821.png

Appreciate your help!

Helpful resources

Announcements
Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Center-of-Excellence-Starter-Kit-cropped 768x460.png

The Total Economic Impact™ of Power Virtual Agents

Read this 2021 commissioned study, conducted by Forrester Consulting.

Top Solution Authors
Users online (1,404)