cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
amalinaf
Level: Power Up

Apply to each show empty array

Hi,

 

I wondering why is my flow not working. It said that the array was empty eventhough it have array in it. It happened when I have the same triggers for different flows as I tried it using different connectors. It was able to give the approvel messages and stuff initially but then suddenly the array was empty. The pictures below are as reference.

 

1.pngThe details for apply to each2.pngThere are no details for apply to each

 

Please help me. Thank you in advance 

 

 

10 REPLIES 10
Community Support Team
Community Support Team

Re: Apply to each show empty array

Hi amalinaf,

 

I am not able to reproduce your issue on my side.


To test this issue, I created a flow likes below. When a new entry is created, the flow will be triggered, the action “Start an approval” can be proceeded without issues.

3.PNG

4.PNG

 

Could you please try to recreate the flow on your side? If you are still having the issue, please provide all the inputs in your form, I will try to reproduce this issue on my side.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Super User
Super User

Re: Apply to each show empty array

I have a similar observation.

 

the "run history" shows that the array returned was empty - however in reality the flow succeeded, so the ARRAY COULD NOT HAVE BEEN EMPTY

 

Run history:

bug_report_1_12-1-2017 1-18-47 PM.jpg

 what happens in apply each

bug_report_2_12-1-2017 1-18-47 PM.jpgbug_report_3_12-1-2017 1-18-47 PM.jpgsuccessful output - both 20 received and 20 sent messages

 

 

 

Super User
Super User

Re: Apply to each show empty array

I have a similar observation.

 

the "run history" shows that the array returned was empty - however in reality the flow succeeded, so the ARRAY COULD NOT HAVE BEEN EMPTY

 

Run history:

bug_report_1_12-1-2017 1-18-47 PM.jpg

 what happens in apply each

bug_report_2_12-1-2017 1-18-47 PM.jpgbug_report_3_12-1-2017 1-18-47 PM.jpgsuccessful output - both 20 received and 20 sent messages

 

 

 

Highlighted
azanetell
Level: Powered On

Re: Apply to each show empty array

Did anyone find a solution to this? I am having the same issue. I have a condition after the apply to each and the flow runs but it runs the True and False condition at the same time. I highlighted it in my screen shot. It runs "Update Row" and "Send an Email" after the apply to each. I also attched a screen shot of the "Input Arry Was Empty" error I am getting. Objiously the inot could not have been empty or it would not have been able to successfully run the true condition and update the row in my Excel document. Input array empty.PNGApply to each.PNG

 

 

azanetell
Level: Powered On

Re: Apply to each show empty array

@v-yamao-msft Do you have any ideas for us on this? It seems many people are having this issue.

TimoPertila
Level: Powered On

Re: Apply to each show empty array

I have similar case with you. I have one for each -loop for submitted forms and inside that other for each loop that goes through array.

 

Outputs for each loop gets have several items. But For each says that input array was empty.

 

i noticed that if i do exactly same operations in other flow having not nested for each loops, then everything works.

 

Is there some bug related nesting for each loops?

 

 


@azanetell wrote:

Did anyone find a solution to this? I am having the same issue. I have a condition after the apply to each and the flow runs but it runs the True and False condition at the same time. I highlighted it in my screen shot. It runs "Update Row" and "Send an Email" after the apply to each. I also attched a screen shot of the "Input Arry Was Empty" error I am getting. Objiously the inot could not have been empty or it would not have been able to successfully run the true condition and update the row in my Excel document. Input array empty.PNGApply to each.PNG

 

 



@azanetell wrote:

Did anyone find a solution to this? I am having the same issue. I have a condition after the apply to each and the flow runs but it runs the True and False condition at the same time. I highlighted it in my screen shot. It runs "Update Row" and "Send an Email" after the apply to each. I also attched a screen shot of the "Input Arry Was Empty" error I am getting. Objiously the inot could not have been empty or it would not have been able to successfully run the true condition and update the row in my Excel document. Input array empty.PNGApply to each.PNG

 

 


 

vegafl
Level: Powered On

Re: Apply to each show empty array

I too have found out today that I have a similar issue. I don't know when this started because the flow always results in a successful run. However, I definitely think that this is a bug because as you can see from my flow, it says that the array was empty, but I see in the final output file that there are items from the SharePoint list, so there must be something in that array to populate the file. I do see that not all of the items that I am retrieving from the SharePoint list are coming through. There are items in the SharePoint list that are not in the final output file in Data Lake.

This is a pretty serious issue for my company. 

TimoPertila
Level: Powered On

Re: Apply to each show empty array

I moved my workflow to logic apps. Same workflow works there nicely.

vegafl
Level: Powered On

Re: Apply to each show empty array

This seems to have been fixed now.

 

Capture.PNG

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Users Online
Currently online: 45 members 4,843 guests
Recent signins:
Please welcome our newest community members: