cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
AndrzejSU
Level: Powered On

Approval flow waits indefinitely for approval/rejection when notification email contains attachment

Hello, my approval flow waits indefinitely for approval when "Create an approval" contains attachment.

Without attachment works correctly. This is very repeatable. I add attachments - flow runs without end on "Wait for an approval" action. I remove attachment - everything works OK.

After "Create an approval" action I send an email and the approval/rejection action is performed. If the email contains attachment "Wait for an approval" "hungs".

Not sure whether it matters - the attachment to approval comes from SharePoint list item attachment. I am able to send this attachment using standard email, so getting attachment from list item works properly.

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Approval flow waits indefinitely for approval/rejection when notification email contains attachment

Hi @AndrzejSU ,

 

The issue is confirmed on my side, and other users as link below also have the issue issue:

https://powerusers.microsoft.com/t5/Using-Flows/Approval-given-by-approver-but-sits-in-pending-upto-...

https://powerusers.microsoft.com/t5/I-Found-A-Bug/Why-I-approved-from-flow-quot-Start-and-wait-for-a...

 

I have reported the issue to my product team, if the issue is solved, I will reply here.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
Community Support Team
Community Support Team

Re: Approval flow waits indefinitely for approval/rejection when notification email contains attachment

Hi @AndrzejSU ,

 

The issue is confirmed on my side, and other users as link below also have the issue issue:

https://powerusers.microsoft.com/t5/Using-Flows/Approval-given-by-approver-but-sits-in-pending-upto-...

https://powerusers.microsoft.com/t5/I-Found-A-Bug/Why-I-approved-from-flow-quot-Start-and-wait-for-a...

 

I have reported the issue to my product team, if the issue is solved, I will reply here.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
firstImage

Power Platform Online Conference

Speakers, submit your sessions now! Call for speakers ends Feb. 10!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (4,522)