cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Approval is not working. Error code 500 Bad Gateway

Been trying to configure an approval using MS Flow but getting Bad Gateway error. Tried searching blogs relating to this but nothing seems to work.

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @RickPaliza ,

 

Are you using the Create an approval (V2) action as well?

 

If so, please check the following similar thread:

https://powerusers.microsoft.com/t5/General-Flow-Discussion/Approval-is-not-working-Error-code-500-B...

 

A workaround for this issue is to add anything, even whitespace, to the approval details field. This only happens when there are no actual approval details.

 

Please take a try with it.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

6 REPLIES 6
Community Support
Community Support

Hi @RickPaliza ,

 

How is your flow created? Please share more details on your flow.

 

I have made a simple flow with approval action, no error message occurs.

1.PNG

 

When error code 500 appears, the failure is temporary, please try to resubmit to try the flow again.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Tried resubmitting a few times already but no luck. Can't even attached screenshot in this blog. I think I need to look an alternative for MS Flow. 

Hi @RickPaliza ,

 

To upload a screenshot, please click the Camera icon in Edit mode:

1.PNG

 

By the way, what’s your location?

 

Please provide a URL of your flow.

 

Please help collect more info so that we could take a further look into this issue.

 

Thanks for your understanding.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @RickPaliza ,

 

Generally, if the error code 500 appears, the failure is temporary or transient.

I assume that it might be a temporary issue.

Please take another try with it.

Please feel free post back if the issue still exists, we are always ready to help.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @RickPaliza ,

 

Are you using the Create an approval (V2) action as well?

 

If so, please check the following similar thread:

https://powerusers.microsoft.com/t5/General-Flow-Discussion/Approval-is-not-working-Error-code-500-B...

 

A workaround for this issue is to add anything, even whitespace, to the approval details field. This only happens when there are no actual approval details.

 

Please take a try with it.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Yeah! It works. Nice trick and Thanks Mabel and for this community! Keep it up!

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Microsoft Ignite

Microsoft Power Platform: 2021 Release Wave 1 Plan

Power Platform release plan for the 2021 release wave 1 describes all new features releasing from April through September 2021.

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (37,799)