cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

Approvals v2 suddenly returning "Encountered an internal server error from the XRM API"

We've been using Approval actions in Flow (using V2 approvals - both standard approve/reject as well as premium custom responses) for a number of months now.  Over the weekend, something has changed so approvals are being sent, but when users try to respond, they receive the error "Encountered an internal server error from the XRM API". 

 

Has anyone else run into this recently or see the error?  We haven't made any environment changes, and if I understand the licensing changes correctly, we should be good until Oct 1st 2020 on the P1/P2 model.

 

Thoughts?  Help!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Helper I
Helper I

Re: Approvals v2 suddenly returning "Encountered an internal server error from the XRM API"

Closing this out - this was a Microsoft issue across a wide number of users, not just us.  It took 3 days before they fixed it, after which they started working again with no interaction from our side.  

 

If you see this, just submit an MS ticket and get the process started.

 

Hope this helps someone.

View solution in original post

4 REPLIES 4
Highlighted
Community Support
Community Support

Re: Approvals v2 suddenly returning "Encountered an internal server error from the XRM API"

 

Hi @Gabegia ,

 

I did a quick test on my side and didn't reproduce your problem.

Are you configuring Approval action using a template? The Approval action we can use now is shown below. Please try using the latest version of the Approval action to configure your Flow.

Image reference:

15.PNG

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper I
Helper I

Re: Approvals v2 suddenly returning "Encountered an internal server error from the XRM API"

@v-bacao-msft Yes, I'm using the most updated version of approvals.  I got someone from MS support yesterday & replicated the issue with just a manual trigger and approval - new approvals don't send & existing approvals awaiting response don't approve.  There's not a heck of a lot to show... it's very specifically the approvals block.  

2019-10-08_0833.png

 

Here's the error when you try to respond to an approval that was sent prior to when we had this issue:2019-10-07_1114.png

Highlighted
Community Support
Community Support

Re: Approvals v2 suddenly returning "Encountered an internal server error from the XRM API"

 

Hi @Gabegia ,

 

I am afraid that I can't reproduce this issue on my side. It seems that this is a tenant-specific issue.

Please try to contact Support for further assistance:

31.PNG

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper I
Helper I

Re: Approvals v2 suddenly returning "Encountered an internal server error from the XRM API"

Closing this out - this was a Microsoft issue across a wide number of users, not just us.  It took 3 days before they fixed it, after which they started working again with no interaction from our side.  

 

If you see this, just submit an MS ticket and get the process started.

 

Hope this helps someone.

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Upcoming Events

Experience what’s next for Power Automate

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Solution Authors
Users online (7,385)