cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
trl7391
Frequent Visitor

Bug with HTTP request to Azure DevOps Manual Intervention Resume Function

 

The bug I have is with the HTTP Request to Azure DevOps.  The API call works in the browser (IE, Chrome), but when I modify it to work with the Flow, it fails.  Here is the full Flow configuration:

Manual Interventions 404.pngRelative URI from the above screen shot:   

XXXXDotNetCoe/_apis/Release/releases/111/manualinterventions/33?api-version=4.1-preview.1

URL from the Manual Interventions page:

PATCH https://vsrm.dev.azure.com/{organization}/{project}/_apis/Release/releases/{releaseId}/manualinterve...

 

          What this Flow is trying to do is take an action from the SharePoint List being adjusted - specific column changing to a "Y" from an "N."   The Azure DevOps CI/CD Stage/Task was paused, waiting for a manual intervention to approve that a code review has been completed.   When the SharePoint List change happens(code review has been completed), I am sending the next step an HTTP request to manually resume my CI/CD Release Pipeline Stage - Flow fails here.  We are attempting to Automate the approval so the development team doesn't have to wait to continue the code migration to the next stage. 

There really isn't much error details provided, other than the 404 and the html error message in the body response.  It states the url was not found.  I was wondering if it might have something to do with the VSRM prefix on the url "vsrm.dev.azure.com," which is in the original API url causing the HTTP request to fail?   

Manual Interventions

Error message provided in the body of the Outputs section:

"error": {
    "code"404,
    "source""flow-apim-msmanaged-na-northcentralus-01.azure-apim.net",
    "clientRequestId""XXXXXXXX-a9b8-42c8-9d94-bed9c61255a6",
    "message""The response is not in a JSON format.",}

 

No JSON Response - however there is HTML in the body output:
    "innerError"   Page not found.-LinkID=242573 Service Status and Support      More information about this errorPage not found.         Here are some additional tips      Verify the URL you are trying to access is correct        Additional technical details:  Activity ID:4

1 REPLY 1
tfhegdbn
Helper IV
Helper IV

Looking forward to Microsoft's MVP on how to configure the "Send an http request to Azure DevOps" action, post some more introductory articles.Smiley Indifferent

Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Users online (86,522)