cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dbaldacchino
Regular Visitor

Cannot read property 'properties' of undefined

Hi,

 

I am revising a previously created Flow that was working fine except I needed to improve on filter logic. It basically looks at an Outlook Inbox and if a new message arrives with specific words in the subject, it posts the email body to a channel in Microsoft Teams. I thought I could add some string expression to the "Subject Filter" (ex: regex), but that doesn't seem to be possible. There is an option for "Trigger Conditions" in the Flow's settings, so I used that per this vlog. My expression is: @startsWith(triggerBody()?['Subject'],'Update - Distributing to') but when I test, I get the red error ribbon stating "Cannot read property 'properties' of undefined" (in MS Teams). Is this a bug? Thanks.

 
1 ACCEPTED SOLUTION

Accepted Solutions
dbaldacchino
Regular Visitor

I found the problem...I was testing with previously run data. If I test based on a connection to the Outlook inbox, it runs just fine.

View solution in original post

5 REPLIES 5
dbaldacchino
Regular Visitor

I found the problem...I was testing with previously run data. If I test based on a connection to the Outlook inbox, it runs just fine.

View solution in original post

v-alzhan-msft
Community Support
Community Support

Hi @dbaldacchino ,

 

It seems that your problem has been solved now, please go ahead and mark the post as solved by clicking “Accept as Solution” so that this thread will be marked for other users to easily identify!

 

Best Regards,

Alice

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi, I am experiencing the exact same problem, but I do not understand your solution...  Can you please expand?

I am experiencing the exact same problem but I do not understand your solution.  Can you please expand on what you did to solve?

Hi, I was using previously run data. When testing a flow, you get the option to use data from a previous successfully run flow, or to generate new data (new trigger). When I generated new data (sent a new email to my Inbox to fit the desired criteria), I no loger received the error message. Hope this helps, thanks.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Users online (3,396)