cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RolandsStrakis
Advocate I
Advocate I

Convert time zone

Issue - field Format string not marked as required. If it's empty string, then gives error.

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @RolandsStrakis ,

I have raise the issue to the MS team.

I am afraid  you need select a value of the 'Format string' currently.

Capture6.PNG

If there is any update, I will connect to you immediately.

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

8 REPLIES 8
v-zhos-msft
Solution Sage
Solution Sage

Hi @RolandsStrakis ,

Sorry for that I can't understand your issue clearly.

Could you please share a screenshot of your error message?

I am afraid I need more details to analysis your issue.

 

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Sure, how do I insert an image?

Hi @RolandsStrakis ,

You can upload the image via the Photos button.

Capture12.PNG

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

kenny1
Advocate II
Advocate II

I've got the same issue. My sharepoint list has 5 date/times which aren't compulsory so I have between 1 and 5 date/times which I need to convert to my timezone in flow. What do I? I think I'll hit my nested condition limit.

You won't believe it, but I finally can upload a photo...

Capture.PNG

So, if I don't put format (leave it empty), then flow will fail

Hi @RolandsStrakis ,

I have made some tests on my side, it has the same issue with yours.

Capture2.PNG

As the error message said, I am afraid you must set the 'Format string' value.

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Hi @RolandsStrakis ,

I have raise the issue to the MS team.

I am afraid  you need select a value of the 'Format string' currently.

Capture6.PNG

If there is any update, I will connect to you immediately.

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

FURU
Advocate I
Advocate I

I'm also having trouble with the fact that the format string is required but not marked as required.
<Format> is marked as "required" in the public information.

https://docs.microsoft.com/en-us/azure/logic-apps/workflow-definition-language-functions-reference#c...

convertTimeZone
Parameter:<format>
Required:No
Type:String

Therefore, please mark "Format String" as required or change the function so that it can be executed even if it is blank.

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Users online (18,456)