cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DavidAKleinFS
New Member

Create and Update flow fail to replicate some actions properly

Steps to reproduce

 

  1. Create and save a flow with a "Get File Properties" using a Sharepoint connector
  2. Create a second flow with a manual trigger start with a "Get Flow" power automate actions that pulls the properties from the flow created in step 1
  3. In the next action in the flow created in step 2, create an "Update Flow" action referencing the properties pulled from the step above. Update the flow created in step one with an unmodified version of the flow definition.
  4. An error will occur that looks like this:

Flow save failed with code 'WorkflowRunActionInputsInvalidProperty' and message 'The 'inputs' of workflow run action 'Get_file_properties' of type 'OpenApiConnection' should not have the property 'authentication'.'.

 

This error seems to occur when including some actions but not others. (I've also noticed it on authorization flows). Others have noticed this issue as well - it appears to stem from a recent update to the power automate flows - perhaps an issue with mismatched versions. For example:

 

https://powerusers.microsoft.com/t5/Building-Flows/power-automate-connector-create-flow-failure-Open...

 

Regards,

 

David

0 REPLIES 0

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Top Solution Authors
Users online (21,529)