cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Lance2017
Level: Powered On

Created By Email not working

Hi, I am trying to do a simple approval flow from the template. However, after clicking approve, the email does get sent back to the requester. The following picture is how i created my flow

fow1.PNG

I found out that it does not grab anything from the created by email.

flow2.PNG

I also discovered that if I grab the created by DisplayName, i will get something like the below i:0#.f|membership|ervin@xxx.onmicrosoft.com

 

Please help and advice. 

 

Thanks !

7 REPLIES 7
Highlighted
mmangiante
Level 8

Re: Created By Email not working

Hi @Lance2017

 

how you created the SharePoint list? What are the fields?

 

I have a similar flow in logic like yours and have different behaviour.

 

 

--

Regards,

 

Marco Mangiante

Lance2017
Level: Powered On

Re: Created By Email not working

Hi @mmangiante

 

I'm just trying to create a dummy test case scenario. 

My SharePoint list is created by clicking on "new" > "list".

I added some random fields like "subject" which is a single line of text.

Created By is auto generated by sharepoint.

 

Regards

Lance

Community Support Team
Community Support Team

Re: Created By Email not working

Hi Lance,

 

Did you make sure that you have created this flow using the template? I just tested with the template "Send approval email when a new item is added" and the dynamic content in the "Send email" field should be like this:

Capture.PNG

 

I have tested with this flow and it runs successfully:

 

1.PNG

 

Please try to recreate this flow and test again.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Lance2017
Level: Powered On

Re: Created By Email not working

Hi @v-monli-msft,

 

I used the template... most of the stuff was pre-filled for me. Including the Created By Email.

 

I am not sure what is wrong Smiley Sad

 

Regards,

Lance

Community Support Team
Community Support Team

Re: Created By Email not working

Hi Lance,

 

Notice that my template was filled with  "Author.email" but yours was "Created by email", please try to recreate this template and make sure that you didn't change this field and then have a test.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Flow Staff RajRa
Flow Staff

Re: Created By Email not working

Hi Lance,

 

From your pictures, it looks like the email address may not be correctly formated. Can you make sure the to fields are valid email ids?

 

thanks

 

Lance2017
Level: Powered On

Re: Created By Email not working

Guys, 

 

I did not change anything but my flow is working fine right now. 

No idea what was wrong. 

 

Thanks for trying to help Smiley Happy 

 

Regards

Lance

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

thirdImage

New Flow Community Board!

Check out the new Microsoft Flow Community Blog Topic Suggestion board!

fourthImage

Australia Summit

Travel to Melbourne and network with thousands of peers!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Users Online
Currently online: 25 members 4,560 guests
Please welcome our newest community members: