cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Desktop UI Flow - Request to XRM API failed with error: 'Message: Resource not found for the segment 'flowsessions'

Hi Power Automate team,

 

I'm trying out Desktop UI Flows, using a simple flow that takes a parameter, opens notepad and types it in, then saves the file with a random filename.  I'm able to get the UI Flow to work fine in test mode.  When I try to invoke it from an Instant Flow, it fails with the error shown below (full error message below it).  I have a 2 minute video of the process here:  https://youtu.be/Fl3PMKEDEJU

 

Is this post-release preview jitters or something I'm doing wrong?

 

I'm using a default environment in region North America.

 

uiflow.png

 

{
"error": {
"code": "XrmApiRequestFailed",
"message": "Request to XRM API failed with error: 'Message: Resource not found for the segment 'flowsessions'.\nCode: 0x8006088a\nInnerError: Type: Microsoft.OData.UriParser.ODataUnrecognizedPathException\nMessage: Resource not found for the segment 'flowsessions'.\nStackTrace: at Microsoft.OData.UriParser.ODataPathParser.CreateDynamicPathSegment(ODataPathSegment previous, String identifier, String parenthesisExpression)\r\n at Microsoft.OData.UriParser.ODataPathParser.CreateFirstSegment(String segmentText)\r\n at Microsoft.OData.UriParser.ODataPathParser.ParsePath(ICollection`1 segments)\r\n at Microsoft.OData.UriParser.ODataPathFactory.BindPath(ICollection`1 segments, ODataUriParserConfiguration configuration)\r\n at Microsoft.OData.UriParser.ODataUriParser.Initialize()\r\n at System.Web.OData.Routing.DefaultODataPathHandler.Parse(String serviceRoot, String odataPath, IServiceProvider requestContainer, Boolean template)\r\n at System.Web.OData.Routing.DefaultODataPathHandler.Parse(String serviceRoot, String odataPath, IServiceProvider requestContainer)\r\n at Microsoft.Crm.Extensibility.ODataV4.Routing.CrmODataPathHandler.Parse(String serviceRoot, String odataPath, IServiceProvider requestContainer)\nInternalException: '."
}
}

2 ACCEPTED SOLUTIONS

Accepted Solutions
Anonymous
Not applicable

Re: Desktop UI Flow - Request to XRM API failed with error: 'Message: Resource not found for the segment 'flowsessions'

I found the answer to this issue in the comments of the original announcement: http://disq.us/p/25hsod0

 

"That means that this feature is not yet available for your environment. You can try this out by creating a new environment, or, wait until the feature is rolled out everywhere, which will be a few weeks."

 

Also in the original announcement (Nov 6th): "The public preview of attended automation will be enabled for all new environments by the end of the week and enabled for all existing environments before the end of November."

 

Hope that helps! I created a 30 day environment to validate and all is working well with that.

 

View solution in original post

Microsoft
Microsoft

Re: Desktop UI Flow - Request to XRM API failed with error: 'Message: Resource not found for the segment 'flowsessions'

I got an answer from a software engineer from Microsoft. You need to create a new environment to avoid this error. This happens only in existing environments and Microsoft is working to backfill existing environments.

View solution in original post

29 REPLIES 29
edim
Frequent Visitor

Re: Desktop UI Flow - Request to XRM API failed with error: 'Message: Resource not found for the segment 'flowsessions'

I'm getting a the same response with UI Web Flows.

Community Support
Community Support

Re: Desktop UI Flow - Request to XRM API failed with error: 'Message: Resource not found for the segment 'flowsessions'

Hi @topness,

 

Please refer to this video, it will help you something during you create UI flow:

https://www.youtube.com/watch?v=2UgZaSM2tq8

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Re: Desktop UI Flow - Request to XRM API failed with error: 'Message: Resource not found for the segment 'flowsessions'

@v-litu-msft thanks so much for the response.  In that video the speaker creates a UI flow while authoring an instant flow.  In this video I follow that process:

- create an instant flow and a UI flow from an action within that

- successfully test my UI flow (types text in notepad)

- when testing from an instant flow, UI flow action fails with the message above.  

 

I've talked with another person (besides @edim's report above) that is experiencing this.  Can you help us move past it?

 

https://youtu.be/AJA6VaG_N4M

edim
Frequent Visitor

Re: Desktop UI Flow - Request to XRM API failed with error: 'Message: Resource not found for the segment 'flowsessions'

@v-litu-msft , Thanks for the response.

I can't seem to get past the flowsessions error. 

The UI Web Flow works in Selenium with no errors. When added to the UI flow web card, card is able to recognize the parameters. But on testing the API failed error continues to occur.

Is there a glitch in the system?

Re: Desktop UI Flow - Request to XRM API failed with error: 'Message: Resource not found for the segment 'flowsessions'

@v-litu-msft I also got a comment on my video from another person experiencing this.  Were you able to duplicate this issue?

monty-psc
Regular Visitor

Re: Desktop UI Flow - Request to XRM API failed with error: 'Message: Resource not found for the segment 'flowsessions'

I am also experiencing this issue.  

rmprecioso
Regular Visitor

Re: Desktop UI Flow - Request to XRM API failed with error: 'Message: Resource not found for the segment 'flowsessions'

I am also experiencing this. Does it have to do with the environment or organization policies that I am in?

austrisv
New Member

Re: Desktop UI Flow - Request to XRM API failed with error: 'Message: Resource not found for the segment 'flowsessions'

#metoo 😞

using web ui. flow works like a charm from selenium, but when try to execute/test flow - then this 'flowsessions' error 😞

edim
Frequent Visitor

Re: Desktop UI Flow - Request to XRM API failed with error: 'Message: Resource not found for the segment 'flowsessions'

@v-litu-msft , is there an update on this issue. It appears not to be a localized or individual issue only. My company wants to move over to MS for RPA instead of our current RPA tool, but we can't if this issue is not resolvable. 

Thank you for the help.

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Automate Community!

firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Users online (6,880)